Dreamfactory has bug, Big size parameter Error


#1

My English level so low.
Please understand.

  • Database
    MariaDB

  • my.cnf
    max_allowed_packet = 128M

  • procedure
    CREATE PROCEDURE test(IN query LONGTEXT)
    BEGIN
    SELECT LENGTH(query);
    END

I try send parameter size 44MB string with mysql library.
It success.

But i try send parameter size 44MB string with dreamfactory.
It failed.

So i try send parameter size <= 10MB string with dreamfactory.
It success.

2.0.4 and 2.3.0 dreamfactory version both failed.

Help me please.


#2

Hello @1112,

Can you send over your POST parameters?

Have you checked out this resource: http://wiki.dreamfactory.com/DreamFactory/Features/Database/Records#Common_Parameters_and_Usage

Thanks, I am still looking into this for you.
@AlexBowen


#3

Hello @AlexBowen

Request Param

  • Version 2.0.4
    {
    “params”: [
    {
    “name”: “query”,
    “value”: “AAAAAAAAA…”,
    “param_type”: “IN”,
    “length”: [value Length]
    }
    ]
    }

  • Version 2.3.0
    {
    “params”: [
    {
    “name”: “query”,
    “value”: “AAAAAAAAA…”
    }
    ]
    }

Response Body

  • Success (<= 10MB)
    Length = 10000000

  • Failed (> 10MB)
    Whoops, looks like something went wrong.


#5

Hello.

Anyone help me PLEASE!!


#6

This is likely due to PHP settings. Best guess is either max_execution_time or memory_limit need to be increased in php.ini.

What’s the error you get back when it fails?


#7

OOOOOOOHHHHHHH!!!

Thank you @drewpearce !!

I change memory_limit 128MB -> 1G.
Then it Success!

But…
Why PHP need 1G memory for send 50MB Post Parameter??

It is mystery…