Dreamfactory https access


#1

Dreamfactory access over https is not working (access over http works)
Current Setup:
-Dreamfactory docker image from bitnami at docker hub
-ssl port reassigned in docker-compose as 1443:443
-digitialocean ubuntu 16.04 server with nginx and docker
-nginx secured via letsencrypt and letsencrypt certificates stored under /etc/letsencrypt/live/

I have tried the following with no success:
docker run -v /host/path/to/certs:/container/path/to/certs -d IMAGE_ID "update-ca-certificates"
per this SO. For the host path, I have tried both with the /etc/ssl/certs as well as the /etc/letsencrypt/live/

For the container path, I have tried /var/lib/docker/volumes/…/apache/conf/bitnami/certs/ and /var/lib/docker/overlay2/…/opt/bitnami/apache/conf/bitnami/certs/

Also edited bitnami.conf virtualhost section for SSL per this link by adding appropriate domain name. The links were different in my bitnami.conf and left them as is (they were generally in the pattern of /opt/bitnami/… and not /Applications/dreamfactory-2.1.2-1/…)

I continue to get certificate error when trying to access dreamfactory over https - thoughts/inputs on resolving this much appreciated


#2

The first issue is because apache was not able to start, probably because of the certificate change.
I believe that the certificates are not in the format that apache expect.

Could you please compare the original server.crt and server.key files and the ones that you are mounting? Have they the same format?

The files should follow this structure:

server.crt

-----BEGIN CERTIFICATE-----
...
-----END CERTIFICATE-----

server.key

-----BEGIN RSA PRIVATE KEY-----
...

-----END RSA PRIVATE KEY-----

The second issue also suggests that there is an incompatibility in the certificate format.