Dreamfactory version showing 2.1.1 after installing 2.1.2


#1

Just installed the latest Dreamfactory 2.1.2 from this link

The installation went through smoothly but when I check the version information from the System Info overview - I see the following:

DreamFactory Instance

Admin Application Version: 2.1.5

DreamFactory Version: 2.1.1

System Database: mysql

Install Path: /opt/dreamfactory-2.1.2-0/apps/dreamfactory/htdocs/

Log Path: /opt/dreamfactory-2.1.2-0/apps/dreamfactory/htdocs/storage/logs/

Log Mode: single

Log Level: WARNING

Cache Driver: file

Cache Path: /opt/dreamfactory-2.1.2-0/apps/dreamfactory/htdocs/storage/framework/cache/

Demo: false

Shouldn’t the DF version show 2.1.2? I flushed / cleared the cache etc

The Bitnami changelog for the version that I downloaded shows this

============ CHANGELOG =============

Version 2.1.2-0 2016-05-02

  • Updated DreamFactory to 2.1.2
  • Updated Nginx to 1.10.0
  • Updated PageSpeed to 1.9.32.14
  • Updated MongoDB to 3.2.5
  • Updated PHP to 5.6.20
  • Updated MariaDB to 10.1.13
  • Updated PostgreSQL to 9.5.2
  • Updated phpMyAdmin to 4.6.0

I had gone through a tedious process of completely removing 2.1.1 but now I still see 2.1.1. Any comments? Thanks


#2

Just checked the mongod from command line and it shows the version as

2016-05-03T17:29:27.133+0000 I CONTROL [initandlisten] db version v3.2.5

Which means that the version is 2.1.2 but the details is picking up data from static file? :neutral_face:

The admin UI hasn’t changed in any way, probably that’s another reason I got a little confused. Btw any words on what could’ve (or is) the reason? Thanks


#3

And what happened to the local MongoDB service :disappointed: It is no longer there


#4

There was a problem with the installer files that has been corrected. Now it will install 2.1.2 as expected. It should also install MongoDB. Let us know if it doesn’t.


#5

Great thanks. I just downloaded / installed the latest version from Bitnami and everything works as expected. The version information, MongoDB all looks and connects fine. Thanks for fixing this real quick :clap:

Btw I have seen this error in the dreamfacory.log file. Wonder if this affects anything

[2016-05-01 10:51:09] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:51:09] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:51:14] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:52:53] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:52:53] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:52:59] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:53:43] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:53:43] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-01 10:53:49] production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] [1045] Access denied for user ‘forge’@‘localhost’ (using password: NO)
[2016-05-04 05:02:32] local.ALERT: Could not get cors config from DB - SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘bitnami_dreamfactory.cors_config’ doesn’t exist (SQL: select * from cors_config where enabled = 1)
[2016-05-04 05:02:38] local.ALERT: Could not get cors config from DB - SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘bitnami_dreamfactory.cors_config’ doesn’t exist (SQL: select * from cors_config where enabled = 1)