Error on tc.log file when restarting bitnami service


#1

I’m getting an issue consistently when trying to restart the bitnami dreamfactory service. I run the ctlscript.sh restart, but then the process gets an error when starting mysql. In the logs it says there’s an error with the tc.log file. I rename the /opt/bitnami/mysql/data/tc.log file and then restart and it works correctly. The error happens every time I restart so it wasn’t a one-time thing. Installed on google cloud bitnami install.


#2

Glad to see its not just me. I’m also on the google cloud bitnami version and every single time I need to restart the server, I have to delete the same tc.log file. If I don’t, the whole database stays down. This is with two separate installs, not just one.


#3

@crystaltaggart57 are you still experiencing this?

@sal thanks for letting us know.

We will certainly investigate this, but this also seems like an error on Bitnami’s end.

Thanks,
@AlexBowen


#4

FYI: I’ve posted on the Bitnami - DreamFactory community to see if we can get a response there too:


Sometimes not able to restart mysql service using ctlscript.sh stop / start (tc.log file issue)
#5

Hey there, @sal & @crystaltaggart57 I’ve got an update.

The Bitnami folks were unable to reproduce the issue, and will need some additional information in order to solve the problem.

  • Did you perform any modifications in the stack?
  • Which steps did you reproduce in order to get the error?
  • Could you post here the tc.log file?

Thanks,
@AlexBowen


#6

@AlexBowen

Hi. I changed a parameter in apps/dreamfactory/htdocs/config/df.php. I changed “always_wrap_resources” to false. That was the only change I made on the default install.

According to Json response / records without "resource" and document id there is a second change to be made in apps/dreamfactory/htdocs/bootstrap/cache/config.php. However I am unable to locate this file to make the second change.

I tried setting “always_wrap_resources” to true again in apps/dreamfactory/htdocs/config/df.php and the server rebooted fine again so that seems like that might be the issue.


#7

Thanks @Sal for following up!

^^ That’s good to hear.

Are you using Bootstrap? Because that may have just been specific to his setup.


#8

the file bootstrap/cache/config.php only exists if you have cached your configuration. If it doesn’t exist, you don’t need to edit it.


#9

Hi,

I have the same problem, but different boundary conditions like the above mentioned case:

The first restart of the bitnami services via /bitnami/ctlscript.sh stop / start led to the same error as discussed here before. So I simply deleted /bitnami/mysql/data/tc.log and I could restart it again.
The days after, I tested this several times and each time was successful: all services could be started.

But after 1 week working with it, the error restarting the bitnami services occurred again.

In my case, I never changed “always_wrap_resources” to false in apps/dreamfactory/htdocs/config/df.php. It’s set to true from the beginning.
Neither I performed changes in other config files.
Neither I have this problem every time restarting the bitnami services.

Why do I get this error sometimes and sometimes not?
I guess this is an indication, that my bitnami installation is not running reliably?

Thank you in advance for any hint
Best Regards