Guest user setup to access only the Database service

authorization
authentication

#1

Hello,
I am using the builtin local DB and I am trying to access a GET on https://my_dsp/rest/db/my_table from Postman as a guest(without any kind of authentication). I am getting

"context": null,
"message": "No application name header or parameter value in request.",
"code": 400

Here is what i did as per the instruction

  1. Setup Schema and added data to the existing Database service which comes with the dsp
  2. Set up a role name and desc
  3. gave a GET service access(Database) to the role with Component * for all. Nothing is done in User tab or lookup key
  4. Ticked on Config - > allow guest user and selected the role

Its working fine from API Docs (/db/{table_name}) but cant access it from Postman or other place. All the settings are updated and I flush the system cache as well. What am I exactly missing? Some help will be highly appreciated.

Thanks


Problem to access DreamFactory APIs from PostMan(Google Chrome Client)
#2

You will need to pass the application name to your DSP when making calls to it. This can be done through headers or parameters. This page on our wiki has some great insight on this topic: https://github.com/dreamfactorysoftware/dsp-core/wiki/Common-Headers-Parameters


#3

@drewpearce, this url is broken! Have almost 2 years! :frowning2:


#4

It’s a 2 year old thread. Don’t be surprised if there are broken links.
All documentation is now on the Wiki, including the information referenced above. I’d specifically recommend checking out the Common Headers and Parameters section, and the Authentication and Authorization tutorials.

Also, since this thread was for the v1 product, I’m moving it to the legacy category and closing it.


#5