Inserting usable timestamps in PostgreSQL


#1

I’m going to be inserting and query records via the dreamfactory rest
interface into a PostgreSQL back end.
How i can add a row to a table with datatype “timestamp without time zone”

I have tried
{
“resource”: [
{
“date”: “2016-01-01 01:00:00”
}
]
}"

and receive the bellow response
{
“error”: {
“context”: null,
“message”: “No record(s) detected in request.”,
“code”: 400
}
}


#2

I’m not very familiar with this datatype. Do you have any data already in this format? If you can GET the data and see what it looks like you should be able to extrapolate the proper way to insert it. I can check and see if there are any known bugs around this.


#3

Yes i have imported data to the table using the pgAdmin.
With the GET command i get:
{
“date”: “2016-01-01 02:00:00”
}


#4

What version of DreamFactory is this? I’m not seeing this behavior in 2.2


#5

Sorry for the late reply.
I found the error, it was on the configuration of the database.
I delete the db and create a new one and the problem was solved.