Install error: Index column size too large


#1

I am following the instructions on: http://wiki.dreamfactory.com/DreamFactory/Installation

When I execute:

$ php artisan df:setup

I get the following error:

SQLSTATE[HY000]: General error: 1709 Index column size too large. The maximum co lumn size is 767 bytes. (SQL: alter table user add unique user_email_unique( email))

I Googled this, and learned that innodb_large_prefix should be enabled. As this already is enabled on my server, I don’t know what to look for next. Does anyone have an idea?

Thanks & regards,
Erik


#2

This is solved by changing the mysql engine setting in config/database.php:

        'engine'    => 'InnoDB ROW_FORMAT=DYNAMIC',

Thanks & regards,

Erik