Is it safe to upgrade from 1.6.10 to 1.7.6 from the config?


#1

I am using the Bitnami installation and last time that broke my entire server and it took half a day to sort out the issue.

Should I just go on and upgrade? I still can’t backup my database.

Cheers and many thanks for the epic product.


#4

When Bitnami packages are installed there is a default user that it is installed by. This user is different than the user that we expect it to be, and the installer.sh doesn’t pick up on it. We are working to fix this.

Solution

  1. Go into your htdocs folder inside of the bitnami install and identify the owner and group.

  2. Run installer.sh (this unfortunately uses the logged in user currently instead of root, thus the commands below)

  3. Change the owner and group back to its original value.

Example where owner is root and group is daemon, root:daemon.

sudo scripts/installer.sh 
sudo chgrp -R daemon *
sudo chgrp -R daemon .*
sudo chown -R root config log vendor web storage

Or, if you’d like to just do it in one line:

$ sudo ./scripts/installer.sh && sudo chgrp -R daemon * .* && sudo chown -R root config/ log/ vendor/ web/ storage/

Thanks,

Mark


#5

sorry for being a newbie :blush: but that installer upgrades the server? or I will need to upgrade first then run the installer?


#6

Just run that installer and it’ll upgrade everything for ya.

Thanks,

  • Mark

#7

yeah thats what i thought. The installer ran fine but the version still shows the old one. Do I have to clear the browser cache or something?


#8

yes, restart apache, reload frame, refresh screen and you’re good to go!

thanks,

mark


#9

i restarted the amazon instance, reloaded and cleared the cache. Still the old version. Is there a way to check for the version in bitnami?


#10

Forgot an important step:

perform a /web/logout - e.g. localhost/web/logout - then restart apache… flush cache on dsp and browser through admin console.

you can easily check version by going into the config tab on the left side of your admin console.

You can get your system config, for example, running on localhost by doing the following:

http://localhost/rest/system/config?app_name=launchpad

Thanks,
Mark


#11

What do you mean by a web logout? I never ran DreamFactory on my local machine. I only use the amazon s3 instant. I honestly have very limited knowledge about server development (That’s why i am using dreamFactory from the first place)

That’s what is shown in my console still

I can try to press update and if it didn’t work i rerun the installer from the terminal like you told me. Will that work?

Is there a way to tell the version of DreamFactory running on the bitnami instance from the terminal?

Thanks a lot Mark for your extensive help I really appreciate it!


#12

Click the green upgrade button. The process behind the scenes pulls latest dsp_core from github, the installer runs, and composer is also updated.

After success here you’ll need to update the db and schema. This is done by appending /web/logout to your DSP_URL.

Finally, Be sure to restart Apache. Clear cache, reload frame…

Looking forward to successful results.

Thanks man,
Mark


#13

what is a DSP_URL and how can i reload a frame?

how long it takes till the installer runs usually after I press the upgrade?

By restarting Apache. You mean I should restart the amazon server instance that’s running DreamFactory?

Sorry that i am asking too many questions :slight_smile:


#14

say it was www.test.com

you would put http://www.test.com/web/logout


#15

so i tried to upgrade from the website and thats what happened :frowning:

And of course my entire server is down again. Tha[quote=“Objective_neo, post:15, topic:270”]
/web/logout
[/quote]

Okay that’s how I sorted it out

1- I logged into bitnami
2- Ran that from inside the htdocs of the app sudo ./scripts/installer.sh && sudo chgrp -R daemon * .* && sudo chown -R root config/ log/ vendor/ web/ storage/
3- made a log out
4- Works fine now again.


#16

Will I still run into these problems upgrading from 1.6.10 to 1.7.8 on ubuntu 12.04 64bit server and bitnami installer?


#17

Yes - here is the process that you will go through:

  1. Launch your DSP and go into admin console -> config -> hit upgrade (1.7.8)

*this pulls down the dsp_core

  1. If a white page pops up - append /web/logout to your dsp_url

  2. Go into your terminal and navigate to the /apps/dreamfactory/htdocs folder

  3. Important: note the owner:group of the folders/files within this folder

  4. Perform the following commands (based on the owner:group)

in this example we will have owner = root and group = daemon

sudo ./scripts/installer.sh
sudo chgrp -R daemon * .* 
sudo chown -R root config/ log/ vendor/ web/ storage/
  1. Restart Apache

Let me know if you have any questions.

Thanks,

  • Mark

#18

Serval times I hit update,then all site become blank!
if safe ,I think it will work without any option,Indeed,it seems still have many things to do,during this work,we could make mistake…so I don’t think it’s safe,at least current version.


#19
********************************************************************************
  DreamFactory Services Platform(tm) Darwin Installer [Mode: Bitnami v1.3.10]
********************************************************************************

  * notice:	OS X installation: Apache user set to "_www"
  * info:	Install user is "ok"
  * info:	Composer pre-installed: /Applications/dreamfactory-1.7.6-0/apps/dreamfactory/htdocs/composer.phar
  * info:	Checking for package manager updates
PHP Warning:  PHP Startup: Unable to load dynamic library '/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pgsql.so' - dlopen(/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pgsql.so, 9): Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
  Reason: Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pdo_pgsql.so' - dlopen(/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pdo_pgsql.so, 9): Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
  Reason: Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0 in Unknown on line 0
  * info:	External modules updated
  * info:	Checking file system structure and permissions
  * notice:	Error changing ownership of local files. Additional steps required. See note at end of run.
  * info:	Installing dependencies
PHP Warning:  PHP Startup: Unable to load dynamic library '/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pgsql.so' - dlopen(/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pgsql.so, 9): Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
  Reason: Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pdo_pgsql.so' - dlopen(/Applications/dreamfactory-1.7.6-0/php/lib/php/extensions/pdo_pgsql.so, 9): Library not loaded: /usr/lib/libsasl2.2.dylib
  Referenced from: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
  Reason: Incompatible library version: LDAP requires version 3.0.0 or later, but libsasl2.2.dylib provides version 0.0.0 in Unknown on line 0

Seems fail again!


#20

Hey,

After you hit update, did you apply /web/log to your dsp_url root?

Also, please follow the instructions listed on this topic

Thanks,


#21

Yes, I did, tested in osx


#22

Did this resolve your issue?

Thanks,

  • Mark