Lots of issues/critical errors with the Scheme editor


#1
  1. I can’t delete or create new properties I keep getting that error CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

  2. If I have a timestamp on create it keeps setting the default value to 0000-00-00 00:00:00 which causes another error to blow up.

  3. Sometimes I get an error and the changes go through then I can’t reverse them.

  4. Some of my data changes don’t get saved! I changed the server URL yesterday. Maybe that is causing the bug?

Can you please advice what to do, this is really becoming very frustrating to handle. Is there anyway to access the database without that editor?


#2

So, you’re running on Linux, correct? AWS EC2 w/ Linux OS?

  1. This is a situation where it is an error within the SQL syntax - what are you trying to perform and with which sql statement?
    Sounds like you’re trying to use either an unsupported SQL verb, or potentially not using a quote when you should be… Give me specifics here and I can tell you more.

  2. Are you saying that the time stamp on anything you create defaults to all zeros? What is the specific error that this causes?

  3. I need a specific scenario of what you’re referring to here: what is the sql statement are you using? There is a rollback option, so that if an error does occur, it will rollback to previous state. Or have you enabled this option and you’re still getting an error…? If so, please be specific as possible on what type of error you’re getting.

  4. Is this because of a timeout issue? You changed your DSP URL via hosted edition?

Being that you’re on a local install - you should be able to just access phpmyadmin directly if you’re having this much difficulty with the schema editor within the admin console.

Also, if I don’t have correct login info it will throw me a 401 - login/pass don’t match on the backend… 403 errors means that I don’t have access to calling a certain REST verb for that specific application. Point being, when you say there is an error, it would benefit both of us greatly if you could be as specific as possible, so that we can diagnose in order to find the right solution.

Thanks man - apologies for the delay on getting back!

  • Mark

#3

okay to be exact

Make a new column with the following:

Type: timestamp_on_create
Database: timestamp
Allows Null: No

The default value for that field will always be 0000-00-00 00:00:00 next time you open the scheme and will cause an error trying to edit anything.

As for my data not saving issue. I also figured it out exactly.

Any columns with the data type “text” will not save. String works fine.


#4

Okay - let me do some testing and get a bit of help from our engineers to see what we can do to get you up and running properly - I am looking at your constraints issue now… thanks