No active applications for a new user


#1

After creating an active role with access to a particular stored function within an active service, and then creating an active user assigned to that role for the appropriate service, logging in with the user gives a message of ‘Sorry, it appears you have no active applications.’ All settings within Apps/User/Roles/Services seem to be in order here as far as I can tell… not sure if there is something I am over looking. Any thoughts would be appreciated. Thanks!

  • I’ve added a temporary role for file access to see if anything would show up when logging in as the created user, and that seems to work. Still no idea why the service I have created does not show up when logged in as the created user.

#2

Sorry that it’s been so long since you got a response. It looks like you’ve hit everything I’d normally suggest looking at. Double check that:

  • the active checkbox is checked on both the app and the service
  • the app has a default role on the service that works
  • the role has at least GET permissions on the service. Make sure permissions are assigned on both service/ and service/*

For troubleshooting, I’d set a default role on the service for the application. Go to the docs and get the /_proc or /_schema url. Add ?api_key=[longAPIkeyFROMappHERE] using the API key for the app to the end of that URL and paste it into your browser in private mode to see if the permissions are right and ensure that the service is responding. The idea is to narrow down if it’s an issue with the user permissions or an issue with the app or service.

You might also try clearing the cache in config.

Hope that helps!
Josiah