Nothing on port 8080 - Bitnami install inside Vagrant / Ubuntu 16.04


#1

Using a MacBook Pro to host Vagrant. I have no trouble getting an Nginx Web server to work well if I provision the box with it so I’m sure the port mapping to the Mac in the Vagrantfile is fine. However, since DF2 also includes Nginx I don’t provision with it when installing DF2. Nothing else has been installed in the box so very clean.

  1. The install inside a Vagrant box went well, no errors.

  2. I checked the ports in Ubuntu and Apache is serving on 8080, as is MySQL / MariaDB and MongoDB. Somewhere there should be an Apache Web page. In Vagrantfile: config.vm.network “forwarded_port”, host: 8080, guest: 8080.

  3. My Mac browser, Chrome, is: localhost:8080 but nothing is loaded. Same with Safari.

  4. I’ve checked the Apache httpd.conf and all seems well. ServerRoot “/home/ubuntu/df2/apache2”

  5. In desperation I’ve tweaked the URL such as localhost/df2:8080 and http://127.0.0.1/home/ubuntu/df2/apache2/htdocs with and without :8080 but no help.

Any clue how to get a browser on my Mac to show the DF2 admin view?


#2

I figured out the answer :slightly_smiling_face:

I had to suspend and restart Vagrant, ssh into the box, cd df2 directory, then run
$ ./ctlscript.sh start

It seems that will all my thrashing around the df2 servers weren’t automatically starting when the box was re-booted. Originally it did that and I didn’t notice that it stopped. Therefore with the correct settings there was still no DF2 setup page.