Older bitnami stack for dreamfactory 1.9.4, need v8js


#1

Hi, could you please provide any link to download DF 1.9.4 ?
I shipped to 2.0 but it is not easy to understand with local db services which we used before. Now i am shifting back to 1.9.4 from github but CANNOT get v8js installed on our debian… really need to solve this issue of v8js.
When writing server side script, fatal error occurs, and there is no such unique and complete instructions on web…
or could you give instructions to manually get libv8.io and place it somewhere and then install php extensions??
pls pls help


#2

Bitnami may be able to provide you older stacks. We don’t have access to Bitnami’s storage of past versions.

The 1.x DreamFactory codebase is still available of course. https://github.com/dreamfactorysoftware/dsp-core

Compiling and enabling V8js is of course up to you. We have found this repository helpful for compiling and running V8js on various platforms: https://github.com/phpv8/v8js

In DreamFactory 2.0, V8js is supported alongside PHP and Node.js scripting.


#3

thanks @jeffreystables, actually i know DF 2 has extra enhanced features…but our apps already use old mechanism of REST apis !!! in order to make the apps work with df 2, one should reproduce request -> response cycle of df 1.9.x otherwise unexpected behaviour will occur on our clients !!!

Any solution for reproducing service definitions easily any how ??
(still working around to get V8js … :smile: )


#4

The easiest way to obtain service configurations is to pull them by calling GET api/v2/system/service/{id} and create a new service with the same config on the new instance by calling POST api/v2/system/service/{id}. Both of these calls are documented in API Docs.


#5

thanks for that clue, i will try…
finally i raised up v8js, now i want to give a get request in scripts but cant find way to get on certain ports, even port 80, see:
var _result = platform.api.get(“https://www.google.com:80”);
throw "ok "+JSON.stringify(_result);

//output {

“message”: “ok false”,

}

it always give false if i indicate port number… any idea ??
i tryed to use options… but of no avail…


#6

anything for me pleasee ??? i am stuck … :frowning:


#7

problem solved !!

Reference blog question