Service user is deactivated


#1

While meddling with an experimental installation, the user service was accidentally disabled. The message when trying to log in is

Service user is deactivated

How to get around this problem? Which configuration file will I need to edit to get this back on? :smile:

Cheers,
M&M


#2

After a bit of probing I saw this in the table called “service” in MySQL db.

+-------------------------+-----------+
| name                    | is_active |
+-------------------------+-----------+
| system                  |         1 |
| api_docs                |         1 |
| files                   |         0 |
| db                      |         0 |
| email                   |         0 |
| user                    |         0 |
| mysql                   |         0 |
| mongodb                 |         1 |
| scr-insert              |         1 |
| testdb                  |         1 |
| test-mlabs              |         1 |
+-------------------------+-----------+

Can I just go ahead an issue an update statement to set 0 to 1, for ‘user’ service?

Thanks,
M&M


#3

wow an accidental disabling of service shouldn’t have taken so much time for an answer :anguished:


#4

All services have an “Active” checkbox in the first tab (INFO). Check this box, save and be happy :smiley:


#5

hehehe done…and additionally the application’s cache has to be cleared if underlying database is directly changed. And for that ‘php artisan cache:clear’ has to be executed in the root dreamfactory directory. Here’s a reference to this issue

Cheers,
M.M


#6

Good to know…
Config > Cache > Flush System-Wide Cache, dont do the job?


#7

hmmmm. I was locked out of the system once I deactivated the ‘user’ service …lol, so I didn’t stand a chance :laughing:

Cheers,
M.M


#8

oooh sure… fuck! hhahahhaha


#9

learning things the right way :innocent: