SQL Connection Bitami 2.0.1


#1

Just stood up a new bitnami server with 2.0.1 installed. I currently have two VMs. One with 2.0.0 and one with 2.0.1. The 2.0.0 version is able to connect to a remote sql server database. The 2.0.1 version is not. The only difference I can see is that in the configuration of the service for 2.0.0 there is a driver selection for MS SQL Server/Sybase (which is what works). In 2.0.1, there is only a selection that says “SQL Server”. Do I need to install another driver on 2.0.1 to get SQL to work?

Thanks,
Craig


#2

Are you using the dblib driver to connect to SQL Server from Linux/Mac or the sqlsrv driver to connect to SQL Server from Windows?


#3

Trying to connect to a windows box running sql from bitnami on ubuntu. The same connection string works on my 2.0.0 VM. This is the error I’m seeing in the bitnami log.

H01071: Got error ‘PHP message: REST Exception #500 > Failed to connect to database.\nConnection failed to open the DB connection: SQLSTATE[01002] Adaptive Server connection failed (severity 9)\n’, referer: http://192.168.0.109/dreamfactory/dist/index.html


#4

I also tried connecting to sql server from DF2.0.1 on windows box but getting error Required extension or module 'sqlsrv' is not installed or loaded


#5

@Im_PJ that’s actually a different issue than the one originally reported in this thread. You need to install the Micosoft sqlsrv php drivers. Details on that are here: https://github.com/dreamfactorysoftware/dsp-core/wiki/SQL-Database-Services#sqlsrv


#6

@cmthomps can you share the contents of your freetds.conf file?


#7

Here is the contents of my freetds.conf file:



#   $Id: freetds.conf,v 1.12 2007/12/25 06:02:36 jklowden Exp $
#
# This file is installed by FreeTDS if no file by the same 
# name is found in the installation directory.  
#
# For information about the layout of this file and its settings, 
# see the freetds.conf manpage "man freetds.conf".  

# Global settings are overridden by those in a database
# server specific section
[global]
        # TDS protocol version
;	tds version = 4.2

	# Whether to write a TDSDUMP file for diagnostic purposes
	# (setting this to /tmp is insecure on a multi-user system)
;	dump file = /tmp/freetds.log
;	debug flags = 0xffff

	# Command and connection timeouts
;	timeout = 10


;	connect timeout = 10
	
	# If you get out-of-memory errors, it may mean that your client
	# is trying to allocate a huge buffer for a TEXT field.  
	# Try setting 'text size' to a more reasonable limit 
	#text size = 20971520

# A typical Sybase server
[egServer50]
	host = symachine.domain.com
	port = 5000
	tds version = 5.0

# A typical Microsoft server
[egServer70]
	host = ntmachine.domain.com
	port = 1433
	tds version = 7.0

#8

So I just retested. I’m able to connect to my SQL box now. I’m not entirely sure what changed. Sorry if I created a fire drill.


#9

No worries on our end. Glad it’s working for you!