Ubuntu install instructions issue


#1

I’ve been following the Install Debian Ubuntu instructions, and can’t locate the directory /opt/dreamfactory/platform/web/assets/ from the Git clone (or on GitHub itself). This file is needed at the very very end of install to configure apache.

I receive the error message:

~# sudo chmod 775 /opt/dreamfactory/platform/web/assets/
chmod: cannot access ‘/opt/dreamfactory/platform/web/assets/’: No such file or directory

What is the correct directory for this command?


#2

We’re looking into your issue. Should have an answer tomorrow. Sorry for the delay.


#3

Wanted to do a quick follow-up. I’m still looking into your issue, potentially related to an ownership issue. Is there a particular reason that you’re installing manually? Did you know about the Bitnami LAMP Dreamfactory packaged installation? It’s not quite as cumbersome, but you could have reasons you need to install manually.

Let me know if that’s an option for you and in the meantime know that I’m working on why you’re getting this msg

Thanks.


#4

The Bitnami package for Linux is here.


#5

Thanks both!

I installed with the bitmani packaged installation yesterday, instead of solely waiting for the issue to be resolved. I was simply more familiar with git and Linux, and not so much with using bitmani.

Our school provided us with a barebones Linux server (which is trying at times, in various situations), and we might just use a preconfigured EC2 image to simplify things.


#6

Great, sounds like the Bitnami package will work for you. Let us know if you have any more questions.