Unauthorized. User credentials did not match


#1

I have a strange problem when connecting DF to MariaDB 10.1. To make sure that permissions are not an issue, I created a user with root access and saved the details in the Service. It works fine till I restart the Server. Once restarted DF cannot connect to MariaDB (which is on the same LAN). The error thrown is

{
  "error": {
    "context": null,
    "message": "Unauthorized. User credentials did not match.",
    "code": 401
  }
}

I have set MariaDB to listen on all interfaces. I can even telnet the other machine on 3306, so firewall is not the problem. But just to be doubly sure I even disabled the firewall.

Whereas the same credentials worked before the restart. Nothing’s changed. I have been on this for the last 4 hours. I have also included the port and charset parameters in the connection string. I haven’t deviated from any connection methods / strings etc so this behavior is very strange.

Thanks,
M.M


#2

And I realised one thing - If I hit the save button again, it will connect - that is till another restart. After that it will again throw the Unauthorized, User credentials did not match error. The again if I hit the “Save service” button under services, it will connect, without changing any parameters. Thanks


#3

I do have the similar problem as well.
Issue I found: update username/password in service tab is not really update connection string for service execution.


#4

Problem stay, after disable Nginx…anybody can help?
DF: 2.1.14
Linux Ubuntu
MariaDB running on 3308 instead of 3306


#5

Try testing, doing the same thing using Mozilla Firefox - you may be surprised at the result


#6

The cause is credentials saved in the browser. Delete your browser’s cached login and password for the DSP admin app.