Upgrade composer install issue


#1

Hello,
I have an issue with the “composer install --no-dev” step during the upgrade and I am getting the error
"Your requirements could not be resolved to an installable set of packages."
Problem 1
- Installation request for mongodb/mongodb 1.0.3 -> satisfiable by mongodb/mongodb[1.0.3].
- mongodb/mongodb 1.0.3 requires ext-mongodb ^1.1.0 -> the requested PHP extension mongodb is missing from your sys
tem.
Problem 2
- Installation request for socialiteproviders/manager v2.1.8 -> satisfiable by socialiteproviders/manager[v2.1.8].
- socialiteproviders/manager v2.1.8 requires php ^5.6 || ^7.0 -> your PHP version (5.5.31) does not satisfy that re
quirement.

I am using windows 10, and have used the command “php composer.phar install --no-dev --ignore-platform-reqs” and got the runtime exception error : Could not delete /vendor/dreamfactory/azure-sdk-for-php/composer.lock.

What would be the way to solve this?


#2

@LauraS can you verify the version of dreamfactory you are trying to update?


#3

The version is 2.1.0