# GitHub Installers

**URL:** https://community.dreamfactory.com/c/github-installers/8.md

[Latest](https://community.dreamfactory.com/latest.md) · [Categories](https://community.dreamfactory.com/categories.md) · [Tags](https://community.dreamfactory.com/tags.md)

---

## [About the GitHub Installers category](https://community.dreamfactory.com/t/about-the-github-installers-category/15)

<div class="topic-metadata">

**Author:** [@benbusse](https://community.dreamfactory.com/u/benbusse)\
**Replies:** 0

</div>

Info about installing / upgrading DreamFactory directly from GitHub on Mac OS X, CentOS, Red Hat, Debian, Ubuntu, and Microsoft Windows.

---

## [View \[index\] not found SplashController.php](https://community.dreamfactory.com/t/view-index-not-found-splashcontroller-php/5592)

<div class="topic-metadata">

**Author:** [@amtenace](https://community.dreamfactory.com/u/amtenace)\
**Replies:** 1\
**Last updated:** [February 25, 2025, 10:54pm UTC](https://community.dreamfactory.com/t/view-index-not-found-splashcontroller-php/5592 "2025-02-25T22:54:23Z")

</div>

Hi, i’m trying to install Dreamfactory, I’ve done all the steps without errors but when I try to launch the software I get this error View \[index\] not found on SplashController.php line 53

---

## [Manual installation with nginx on ubuntu 14.04 lts](https://community.dreamfactory.com/t/manual-installation-with-nginx-on-ubuntu-14-04-lts/2545)

<div class="topic-metadata">

**Author:** [@ventis](https://community.dreamfactory.com/u/ventis)\
**Replies:** 18\
**Last updated:** [October 14, 2022, 11:06am UTC](https://community.dreamfactory.com/t/manual-installation-with-nginx-on-ubuntu-14-04-lts/2545 "2022-10-14T11:06:18Z")

</div>

Hi Guys, I installed the latest version of Dreamfactory from github on my ubuntu desktop server 14.04 LTS with an nginx server. I pointed the root of my nginx server to the public folder of my dreamfactory installation. …

---

## [Debian 11 installer](https://community.dreamfactory.com/t/debian-11-installer/5367)

<div class="topic-metadata">

**Author:** [@MrSpock](https://community.dreamfactory.com/u/MrSpock)\
**Replies:** 0\
**Last updated:** [April 16, 2022, 7:07pm UTC](https://community.dreamfactory.com/t/debian-11-installer/5367 "2022-04-16T19:07:56Z")

</div>

Hi, I tried to use the installer from github to install dreamfactory. The system reports that only Debian 9 and 10 are supported. So I looked into the debian.sh file and the comments say that Debian 11 is not yet support…

---

## [DreamFactory on Centos Plesk with Virtual Host](https://community.dreamfactory.com/t/dreamfactory-on-centos-plesk-with-virtual-host/121)

<div class="topic-metadata">

**Author:** [@ikyaqoob](https://community.dreamfactory.com/u/ikyaqoob)\
**Replies:** 9\
**Last updated:** [March 29, 2022, 5:08pm UTC](https://community.dreamfactory.com/t/dreamfactory-on-centos-plesk-with-virtual-host/121 "2022-03-29T17:08:37Z")

</div>

Hi How can DreamFactory be installed on a dedicated server running centos with plesk and having virtual host , If it can run on bitnami stack , sure there must be a way to do thanks

---

## [Problem In Running Multiple Dreamfactory Instances](https://community.dreamfactory.com/t/problem-in-running-multiple-dreamfactory-instances/5219)

<div class="topic-metadata">

**Author:** [@arpiticx](https://community.dreamfactory.com/u/arpiticx)\
**Replies:** 1\
**Last updated:** [November 3, 2020, 4:24pm UTC](https://community.dreamfactory.com/t/problem-in-running-multiple-dreamfactory-instances/5219 "2020-11-03T16:24:57Z")

</div>

Hi, I managed to install a DF instance with MySQL as a backend. The instance is running fine, i am able to create new apps and services. However, when I tried to install the second DF instance (for HA) with same MySQL …

---

## [Session\_start(): ps\_files\_cleanup\_dir: opendir(/var/lib/php5) failed: Permission denied (13)](https://community.dreamfactory.com/t/session-start-ps-files-cleanup-dir-opendir-var-lib-php5-failed-permission-denied-13/935)

<div class="topic-metadata">

**Author:** [@BeerBeer](https://community.dreamfactory.com/u/BeerBeer)\
**Replies:** 3\
**Last updated:** [April 3, 2020, 6:23pm UTC](https://community.dreamfactory.com/t/session-start-ps-files-cleanup-dir-opendir-var-lib-php5-failed-permission-denied-13/935 "2020-04-03T18:23:13Z")

</div>

Hi, I'm running DreamFactory on Debian and regularly face this error. Not only is it annoying, it also terminates active sessions. This is something that should not happen unless the PHP-application overrides the "sess…

---

## [Windows Server Installation - Setup Fails](https://community.dreamfactory.com/t/windows-server-installation-setup-fails/5054)

<div class="topic-metadata">

**Author:** [@pbeverage](https://community.dreamfactory.com/u/pbeverage)\
**Replies:** 1\
**Last updated:** [October 22, 2019, 2:02pm UTC](https://community.dreamfactory.com/t/windows-server-installation-setup-fails/5054 "2019-10-22T14:02:33Z")

</div>

Hello, I have installed DreamFactory in a Linux instance (Ubuntu 18.04) just fine multiple times, hitting MSSQL as the backend, with no issue. However, any time that I try to install to Windows Server (any version), I …

---

## [Server requiring proc\_open to install DreamFactory](https://community.dreamfactory.com/t/server-requiring-proc-open-to-install-dreamfactory/4606)

<div class="topic-metadata">

**Author:** [@Swishy](https://community.dreamfactory.com/u/Swishy)\
**Replies:** 4\
**Last updated:** [November 6, 2018, 5:32pm UTC](https://community.dreamfactory.com/t/server-requiring-proc-open-to-install-dreamfactory/4606 "2018-11-06T17:32:50Z")

</div>

Hello, I am wondering if you can assist? It appears that the function proc\_open is required to install Dream Factory on a Linux web server. I have asked my host to enable it, and they have said: The function proc\_op…

---

## [Best way to install DreamFactory on a VPS](https://community.dreamfactory.com/t/best-way-to-install-dreamfactory-on-a-vps/3396)

<div class="topic-metadata">

**Author:** [@stevejohnson](https://community.dreamfactory.com/u/stevejohnson)\
**Replies:** 16\
**Last updated:** [November 10, 2016, 4:16pm UTC](https://community.dreamfactory.com/t/best-way-to-install-dreamfactory-on-a-vps/3396 "2016-11-10T16:16:58Z")

</div>

Hello, I'm just going through the docs and and trying to figure which is the best way to install DreamFactory. I'm currently on Ubuntu 14.04 which has a percon DB. Went through this article - http://wiki.dreamfactory.c…

---

## [Help to others when installing DF in a VPS, problems & solutions](https://community.dreamfactory.com/t/help-to-others-when-installing-df-in-a-vps-problems-solutions/3863)

<div class="topic-metadata">

**Author:** [@LBat](https://community.dreamfactory.com/u/LBat)\
**Replies:** 3\
**Last updated:** [September 1, 2017, 6:53pm UTC](https://community.dreamfactory.com/t/help-to-others-when-installing-df-in-a-vps-problems-solutions/3863 "2017-09-01T18:53:25Z")

</div>

Hello comunity, I try to help other members about a installation in a server, a "fight" to put this live... uff! I have a VPS server, where have many domains parked. I make a clean installation of DF v2.6.0, where …

---

## [Not able to read the api after fresh install in wamp](https://community.dreamfactory.com/t/not-able-to-read-the-api-after-fresh-install-in-wamp/3994)

<div class="topic-metadata">

**Author:** [@Jose\_Manuel\_Ojeda](https://community.dreamfactory.com/u/Jose_Manuel_Ojeda)\
**Replies:** 0\
**Last updated:** [August 14, 2017, 2:08pm UTC](https://community.dreamfactory.com/t/not-able-to-read-the-api-after-fresh-install-in-wamp/3994 "2017-08-14T14:08:10Z")

</div>

I have a problem when I install df in a wamp, after I finished the setup from github I get this saying that all the basic apps are created, but when I login an select any tab(apps, admin, users) I get a message like …

---

## [Openshift Cartridge Error 503](https://community.dreamfactory.com/t/openshift-cartridge-error-503/3711)

<div class="topic-metadata">

**Author:** [@Paulo\_Henrique\_de\_Si](https://community.dreamfactory.com/u/Paulo_Henrique_de_Si)\
**Replies:** 0\
**Last updated:** [March 14, 2017, 12:00am UTC](https://community.dreamfactory.com/t/openshift-cartridge-error-503/3711 "2017-03-14T00:00:50Z")

</div>

Hi. I'm trying to install Dreamfactory on my Openshift v2 account . The installation is successful but when I try to access the application I get an internal server error, the app log is as follows: PHP Parse error: …

---

## [Table 'dreamfactory.cors\_config' doesn't exist on Fresh Installation](https://community.dreamfactory.com/t/table-dreamfactory-cors-config-doesnt-exist-on-fresh-installation/3715)

<div class="topic-metadata">

**Author:** [@sosukeinu](https://community.dreamfactory.com/u/sosukeinu)\
**Replies:** 0\
**Last updated:** [March 15, 2017, 12:26pm UTC](https://community.dreamfactory.com/t/table-dreamfactory-cors-config-doesnt-exist-on-fresh-installation/3715 "2017-03-15T12:26:10Z")

</div>

Hello, I've fought and fought over the past few days trying to get DF installed as a part of a docker-compose stack. I'm using basically the same compose file that comes from the official DF github. The only real differe…

---

## [OpenShift v3 Docker Installation Error](https://community.dreamfactory.com/t/openshift-v3-docker-installation-error/3577)

<div class="topic-metadata">

**Author:** [@skipatrolmobile](https://community.dreamfactory.com/u/skipatrolmobile)\
**Replies:** 2\
**Last updated:** [February 15, 2017, 7:27pm UTC](https://community.dreamfactory.com/t/openshift-v3-docker-installation-error/3577 "2017-02-15T19:27:57Z")

</div>

Via OpenShift Online, I try to install the Docker image: dreamfactorysoftware/df-docker I get the warning: Image dreamfactorysoftware/df-docker runs as the root user which might not be permitted by your cluster adm…

---

## [2.0 & OpenShift](https://community.dreamfactory.com/t/2-0-openshift/1710)

<div class="topic-metadata">

**Author:** [@skipatrolmobile](https://community.dreamfactory.com/u/skipatrolmobile)\
**Replies:** 17\
**Last updated:** [December 5, 2016, 7:47am UTC](https://community.dreamfactory.com/t/2-0-openshift/1710 "2016-12-05T07:47:03Z")

</div>

The OpenShift cartridge is last updated five months ago: https://github.com/dreamfactorysoftware/openshift-dreamfactory-cartridge Any idea when we can get a new 2.0 OpenShift cartridge for installation on that PaaS? …

---

## [Install on IIS blocked on MongoDB PHP driver not installed](https://community.dreamfactory.com/t/install-on-iis-blocked-on-mongodb-php-driver-not-installed/3290)

<div class="topic-metadata">

**Author:** [@Remi\_Cote](https://community.dreamfactory.com/u/Remi_Cote)\
**Replies:** 1\
**Last updated:** [October 4, 2016, 7:20pm UTC](https://community.dreamfactory.com/t/install-on-iis-blocked-on-mongodb-php-driver-not-installed/3290 "2016-10-04T19:20:13Z")

</div>

Hi. I am trying to install Dream Factory on Windows Server 2008 with IIS. I want to connect to a postgreSQL db and so I have no interest in MongoDB at the moment. Following the instructions (https://wiki.dreamfactory.com/…

---

## [Javacript errors in chrome debugger console](https://community.dreamfactory.com/t/javacript-errors-in-chrome-debugger-console/2917)

<div class="topic-metadata">

**Author:** [@delebash](https://community.dreamfactory.com/u/delebash)\
**Replies:** 1\
**Last updated:** [July 15, 2016, 2:17pm UTC](https://community.dreamfactory.com/t/javacript-errors-in-chrome-debugger-console/2917 "2016-07-15T14:17:12Z")

</div>

Ubuntu 14.04 Nginx DreamFactory 2.2.0 Every thing seems to be working fine, I have setup a table and added data to a mysql database and can get rest info from the Api Docs tab so every thing seems to be working. I hav…

---

## [Persist data in Docker / Move data](https://community.dreamfactory.com/t/persist-data-in-docker-move-data/1891)

<div class="topic-metadata">

**Author:** [@tiptronic](https://community.dreamfactory.com/u/tiptronic)\
**Replies:** 2\
**Last updated:** [June 23, 2016, 1:17pm UTC](https://community.dreamfactory.com/t/persist-data-in-docker-move-data/1891 "2016-06-23T13:17:38Z")

</div>

I'm using the official dreamfactory docker image. Are there some instructions how to upgrade the image without losing any data? Do you plan integrating some ENV variables to persist data outside the image (currently d…

---

## [System service lost from API DOCS](https://community.dreamfactory.com/t/system-service-lost-from-api-docs/2628)

<div class="topic-metadata">

**Author:** [@jmontes](https://community.dreamfactory.com/u/jmontes)\
**Replies:** 0\
**Last updated:** [May 5, 2016, 6:58pm UTC](https://community.dreamfactory.com/t/system-service-lost-from-api-docs/2628 "2016-05-05T18:58:42Z")

</div>

My upgraded instance of DF2, dont have more the SYSTEM SERVICE in API DOCS Admin Application Version: 2.1.6 DreamFactory Version: 2.1.2 Operating System: linux Release: 3.16.0-4-amd64 version: #1 SMP Debian 3.16…

---

## [Github + Apache: Retrieval of /api/v2/system/environment results in 404](https://community.dreamfactory.com/t/github-apache-retrieval-of-api-v2-system-environment-results-in-404/2105)

<div class="topic-metadata">

**Author:** [@mlucas](https://community.dreamfactory.com/u/mlucas)\
**Replies:** 5\
**Last updated:** [April 28, 2016, 1:10pm UTC](https://community.dreamfactory.com/t/github-apache-retrieval-of-api-v2-system-environment-results-in-404/2105 "2016-04-28T13:10:12Z")

</div>

I followed the git installation instructions on the wiki and on github. Laravel correctly serves DF2 on port 8000, but I'd like to use Apache instead. I followed the relevant instructions to have Apache serve the public …

---

## [How to upgrade dreamfactory droplet on digitalocean?](https://community.dreamfactory.com/t/how-to-upgrade-dreamfactory-droplet-on-digitalocean/2581)

<div class="topic-metadata">

**Author:** [@mrvipinkashyap](https://community.dreamfactory.com/u/mrvipinkashyap)\
**Replies:** 0\
**Last updated:** [April 27, 2016, 10:05am UTC](https://community.dreamfactory.com/t/how-to-upgrade-dreamfactory-droplet-on-digitalocean/2581 "2016-04-27T10:05:21Z")

</div>

I have a dreamfactory droplet which is running on DigitalOcean. I am trying to upgrade its dreamfactory version from current DreamFactory Version: 2.0.4 to latest. I tried following steps mentioned in upgrade section of…

---

## [Dreamfactory 2.1.1-2 post installation error running /opt/dreamfactory-2.1.1-2/php/bin/php -q](https://community.dreamfactory.com/t/dreamfactory-2-1-1-2-post-installation-error-running-opt-dreamfactory-2-1-1-2-php-bin-php-q/2562)

<div class="topic-metadata">

**Author:** [@Naveen\_Kumar](https://community.dreamfactory.com/u/Naveen_Kumar)\
**Replies:** 0\
**Last updated:** [April 21, 2016, 6:54am UTC](https://community.dreamfactory.com/t/dreamfactory-2-1-1-2-post-installation-error-running-opt-dreamfactory-2-1-1-2-php-bin-php-q/2562 "2016-04-21T06:54:29Z")

</div>

i am trying to install dreamfactory 2.1.1-2 in centos 7 core but i am getting Error as below.... Warning: Problem running post-install step. Installation may not complete correctly Error running /opt/dreamfactory-2.1.…

---

## [PHP Fatal error (blank page)](https://community.dreamfactory.com/t/php-fatal-error-blank-page/929)

<div class="topic-metadata">

**Author:** [@Roberto](https://community.dreamfactory.com/u/Roberto)\
**Replies:** 15\
**Last updated:** [April 17, 2016, 6:22pm UTC](https://community.dreamfactory.com/t/php-fatal-error-blank-page/929 "2016-04-17T18:22:10Z")

</div>

Hello: I installed dreamfactory for Linux (Centos) with this instructions: https://github.com/dreamfactorysoftware/dsp-core/wiki/Install-CentOS-RedHat All ok, but I get a blank page with this log error: mod\_fcgid…

---

## [403 forbidden! You don't have permission to access / on this server](https://community.dreamfactory.com/t/403-forbidden-you-dont-have-permission-to-access-on-this-server/2491)

<div class="topic-metadata">

**Author:** [@prasong](https://community.dreamfactory.com/u/prasong)\
**Replies:** 0\
**Last updated:** [April 6, 2016, 10:49am UTC](https://community.dreamfactory.com/t/403-forbidden-you-dont-have-permission-to-access-on-this-server/2491 "2016-04-06T10:49:06Z")

</div>

I have success install on my server with Window Server 2008, Apache 2.4 and PHP 5.6. After setup database, i got 403 which i am not sure because of vhost configuration, or not? Here is vhost DocumentRoot "c:/d…

---

## [Install DreamFactory on WAMP](https://community.dreamfactory.com/t/install-dreamfactory-on-wamp/2444)

<div class="topic-metadata">

**Author:** [@prasong](https://community.dreamfactory.com/u/prasong)\
**Replies:** 4\
**Last updated:** [April 4, 2016, 1:41pm UTC](https://community.dreamfactory.com/t/install-dreamfactory-on-wamp/2444 "2016-04-04T13:41:16Z")

</div>

I have setup DF on my windows server 2008 and SQL Server 2012 and apache (WAMP) on this URL DreamFactory. And i found error like this Installation failed. Please run the migration and seeder manually. Whoops, looks li…

---

## [Successful install steps on RHEL/CentOS 7](https://community.dreamfactory.com/t/successful-install-steps-on-rhel-centos-7/1029)

<div class="topic-metadata">

**Author:** [@AlanM](https://community.dreamfactory.com/u/AlanM)\
**Replies:** 5\
**Last updated:** [March 24, 2016, 2:24pm UTC](https://community.dreamfactory.com/t/successful-install-steps-on-rhel-centos-7/1029 "2016-03-24T14:24:18Z")

</div>

The instructions on GitHub for a RHEL install from GitHub sources were pretty good, but didn't work well for me on RHEL/CentOS6, so I decided to try to use a new CentOS 7 install which I have experience administering ove…

---

## [Manual Installation Issue and nginx configuration](https://community.dreamfactory.com/t/manual-installation-issue-and-nginx-configuration/2315)

<div class="topic-metadata">

**Author:** [@markaduffy](https://community.dreamfactory.com/u/markaduffy)\
**Replies:** 2\
**Last updated:** [March 7, 2016, 3:30pm UTC](https://community.dreamfactory.com/t/manual-installation-issue-and-nginx-configuration/2315 "2016-03-07T15:30:27Z")

</div>

Getting the following error after installation. 2016/03/03 13:21:44 \[error\] 8276#0: \*5 FastCGI sent in stderr: "PHP message: REST Exception #404 \> Could not find a service for user" while reading response header from u…

---

## [Is the Dreamfactory version 1.9 available to download/install](https://community.dreamfactory.com/t/is-the-dreamfactory-version-1-9-available-to-download-install/2281)

<div class="topic-metadata">

**Author:** [@rajivperera](https://community.dreamfactory.com/u/rajivperera)\
**Replies:** 2\
**Last updated:** [March 2, 2016, 5:33pm UTC](https://community.dreamfactory.com/t/is-the-dreamfactory-version-1-9-available-to-download-install/2281 "2016-03-02T17:33:46Z")

</div>

DF 2.0 is incompatible with our app that used DF 1.9. Our app code requires quite a lot of code changes to work in 2.0. Is the 1.9 version available to download and install to a new server?

---

## ["MAC is invalid" 500 Error when upgrading from 2.01 to 2.1](https://community.dreamfactory.com/t/mac-is-invalid-500-error-when-upgrading-from-2-01-to-2-1/2220)

<div class="topic-metadata">

**Author:** [@rdubya152](https://community.dreamfactory.com/u/rdubya152)\
**Replies:** 7\
**Last updated:** [March 2, 2016, 3:54pm UTC](https://community.dreamfactory.com/t/mac-is-invalid-500-error-when-upgrading-from-2-01-to-2-1/2220 "2016-03-02T15:54:40Z")

</div>

In a desperate attempt to resolve my V8JS issue I decided to upgrade my DreamFactory instance. I followed these instructions: https://wiki.dreamfactory.com/DreamFactory/Installation#Upgrade and used git to install. I d…

[Next page](https://community.dreamfactory.com/c/github-installers/8.md?page=1)
