# Creating new SQL Server service

**URL:** <https://community.dreamfactory.com/t/creating-new-sql-server-service/2174>\
**Category:** Connecting to SQL\
**Created:** [February 11, 2016, 6:13pm UTC](https://community.dreamfactory.com/t/creating-new-sql-server-service/2174 "2016-02-11T18:13:10Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![dnewbytricore](https://avatars.discourse-cdn.com/v4/letter/d/e8c25b/32.png) [@dnewbytricore](https://community.dreamfactory.com/u/dnewbytricore)\
**Post date:** [February 11, 2016, 6:13pm UTC](https://community.dreamfactory.com/t/creating-new-sql-server-service/2174/1 "2016-02-11T18:13:10Z")

</div>

I am using Dreamfactory 2.1 and Laravel Homestead for my VM.

When I create a new service for SQL Server I am receiving the following error:

Api Error  
Required extension or module ‘mssql’ is not installed or loaded.

Database for the service is set to SQL DB.

Here is my connection string: dblib:host=localhost:1433;dbname=database;charset=UTF-8

Has anyone been able to get Dreamfactory to successfully work with SQL Server using Laravel Homestead?

---

<div class="post-metadata">

**Author:** ![formerstaff](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/formerstaff/32/1133_2.png) [@formerstaff](https://community.dreamfactory.com/u/formerstaff)\
**Post date:** [February 11, 2016, 6:47pm UTC](https://community.dreamfactory.com/t/creating-new-sql-server-service/2174/2 "2016-02-11T18:47:48Z")

</div>

I haven’t used homestead at all, but connecting to MS SQL in linux requires the php sybase driver.  
In ubuntu/debian this is `sudo apt-get install php5-sybase`

[https://wiki.dreamfactory.com/DreamFactory/Installation#Additional\_Drivers\_and\_Modules](https://wiki.dreamfactory.com/DreamFactory/Installation#Additional_Drivers_and_Modules)

---

<div class="post-metadata">

**Author:** ![dnewbytricore](https://avatars.discourse-cdn.com/v4/letter/d/e8c25b/32.png) [@dnewbytricore](https://community.dreamfactory.com/u/dnewbytricore)\
**Post date:** [February 11, 2016, 9:05pm UTC](https://community.dreamfactory.com/t/creating-new-sql-server-service/2174/3 "2016-02-11T21:05:49Z")

</div>

Thank you for this. After additional searching it looks like the need the sybase drivers for PHP 7.

I have installed them using the following command:

`sudo apt-get install php7.0-sybase freetds-common libsybdb5`

I am still getting the error though. Does Dreamfactory work with PHP 7?

---

<div class="post-metadata">

**Author:** ![dnewbytricore](https://avatars.discourse-cdn.com/v4/letter/d/e8c25b/32.png) [@dnewbytricore](https://community.dreamfactory.com/u/dnewbytricore)\
**Post date:** [February 11, 2016, 9:12pm UTC](https://community.dreamfactory.com/t/creating-new-sql-server-service/2174/4 "2016-02-11T21:12:38Z")

</div>

I think that I am encountering the same issue described in: [Unable to connect to SQL Server 2012 on Windows with DF2.0 Beta 2](https://community.dreamfactory.com/t/unable-to-connect-to-sql-server-2012-on-windows-with-df2-0-beta-2/1582) It is looking for the mssql driver but I have the dblib driver selected in my connection string.

---

<div class="post-metadata">

**Author:** ![dnewbytricore](https://avatars.discourse-cdn.com/v4/letter/d/e8c25b/32.png) [@dnewbytricore](https://community.dreamfactory.com/u/dnewbytricore)\
**Post date:** [February 11, 2016, 10:13pm UTC](https://community.dreamfactory.com/t/creating-new-sql-server-service/2174/5 "2016-02-11T22:13:57Z")

</div>

I followed the steps in [https://wiki.dreamfactory.com/DreamFactory/Installation/Databases/SQLServer](https://wiki.dreamfactory.com/DreamFactory/Installation/Databases/SQLServer) for Linux using the apt-get command in my reply above but used the php7.0-sybase package instead. Still not working, any input would be appreciated.

Thank you.
