# Failed to launch service "df"

**URL:** <https://community.dreamfactory.com/t/failed-to-launch-service-df/1969>\
**Category:** GitHub Installers\
**Created:** [December 28, 2015, 10:07am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969 "2015-12-28T10:07:07Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![tejas](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tejas](https://community.dreamfactory.com/u/tejas)\
**Post date:** [December 28, 2015, 10:07am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/1 "2015-12-28T10:07:07Z")

</div>

Hello,

I just installed DreamFactory as per the steps provided on the GitHub page.

Even after completing all the steps. When I try to open the admin page, the following error is shown:

`"Failed to launch service "df": Service not found"`

How can I resolve this, any idea?

---

<div class="post-metadata">

**Author:** ![mattschaer](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/mattschaer/32/914_2.png) [@mattschaer](https://community.dreamfactory.com/u/mattschaer)\
**Post date:** [December 28, 2015, 4:31pm UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/2 "2015-12-28T16:31:19Z")

</div>

@tejas hard to say from the error message alone. Could you provide some more information about your instance? Some useful information would be the type of web server used during installation and operating system. Additionally, DreamFactory does some logging here (may differ depending on your environment): {install directory}/storage/logs/dreamfactory.log

These logs might reveal some useful information in helping us identify the culprit preventing your instance from opening to the admin. page.

---

<div class="post-metadata">

**Author:** ![tejas](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tejas](https://community.dreamfactory.com/u/tejas)\
**Post date:** [December 29, 2015, 5:00am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/3 "2015-12-29T05:00:01Z")

</div>

Hey @mattschaer,

The logs contain the following the error:

```
production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] 
[1045] Access denied for user 'forge'@'localhost' (using password: NO) 

```

Is there any additional setup needed?

---

<div class="post-metadata">

**Author:** ![mattschaer](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/mattschaer/32/914_2.png) [@mattschaer](https://community.dreamfactory.com/u/mattschaer)\
**Post date:** [December 29, 2015, 7:01pm UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/4 "2015-12-29T19:01:51Z")

</div>

@tejas Assuming you installed from GitHub could you tell me what is the system database you are using? Is it MySQL or SQLite? The error message you are receiving can be better interpreted with some more detailed information about the environment in which you’ve installed your DreamFactory instance.

---

<div class="post-metadata">

**Author:** ![tejas](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tejas](https://community.dreamfactory.com/u/tejas)\
**Post date:** [December 30, 2015, 4:37am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/5 "2015-12-30T04:37:42Z")

</div>

Hi @mattschaer,

System database is MySQL. Database is Migrated & Seeded using the setup command.

The environment details are CentOS, PHP 5.5+, MySQL 5.6.+  
Any other details needed?

---

<div class="post-metadata">

**Author:** ![tejas](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tejas](https://community.dreamfactory.com/u/tejas)\
**Post date:** [December 30, 2015, 4:47am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/6 "2015-12-30T04:47:21Z")

</div>

Even DEBUGGING is set to true.

Still the error message is same: "Failed to launch service “df”: Service not found"  
One thing to notice is that, I have “df” in my URL. `Eg- hostname/df/dreamfactory/public.`

Is this “df” in the URL is causing the issue?

---

<div class="post-metadata">

**Author:** ![formerstaff](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/formerstaff/32/1133_2.png) [@formerstaff](https://community.dreamfactory.com/u/formerstaff)\
**Post date:** [December 30, 2015, 3:16pm UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/7 "2015-12-30T15:16:05Z")

</div>

DreamFactory cannot be run as a subfolder of a site. The DreamFactory public directory must be the root of the site in order for it to function properly. You should set up a separate virtual host for your DreamFactory installation.

---

<div class="post-metadata">

**Author:** ![tejas](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tejas](https://community.dreamfactory.com/u/tejas)\
**Post date:** [December 31, 2015, 6:49am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/8 "2015-12-31T06:49:53Z")

</div>

Hi @formerstaff,

Thank You for the update. I created a sub domain & directed it to the public folder of the DreamFactory.

Now just one issue remains is that I get the following error when I open the home page:

```
Failed to load resource: the server responded with a status of 400 (Bad Request)
app.0c282415.js:3

```

Login page form is not loaded as it normally works on local.  
Is it because of CORS? DO we need to set something on server?

---

<div class="post-metadata">

**Author:** ![formerstaff](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/formerstaff/32/1133_2.png) [@formerstaff](https://community.dreamfactory.com/u/formerstaff)\
**Post date:** [January 4, 2016, 1:10pm UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/9 "2016-01-04T13:10:06Z")

</div>

check you dreamfactory log and your apache log to see what specific errors are reported there.

just guessing, but it could be a permissions issue. Make sure that the Apache user (www-data on Ubuntu/debian systems) has read & write access to the storage/ and bootstrap/cache/ directories.

[https://wiki.dreamfactory.com/DreamFactory/Installation#General\_Instructions](https://wiki.dreamfactory.com/DreamFactory/Installation#General_Instructions)

---

<div class="post-metadata">

**Author:** ![tejas](https://avatars.discourse-cdn.com/v4/letter/t/a698b9/32.png) [@tejas](https://community.dreamfactory.com/u/tejas)\
**Post date:** [January 5, 2016, 5:36am UTC](https://community.dreamfactory.com/t/failed-to-launch-service-df/1969/10 "2016-01-05T05:36:37Z")

</div>

Hey @formerstaff,

Checked the logs. Also checked the AJAX call which is made to get the ENVIRONMENT details.  
`http://domain.com/api/v2/system/environment`  
This AJAX call is failing in the index page of Admin Console.

Entered the URL in the browser - It worked.  
Repeated the AJAX call **without headers** using POSTMAN - It worked.  
Repeated the AJAX call **with headers by adding X-DreamFactory-API-Key** using POSTMAN - Error.

Error message:  
\> “message”: “Unknown relationship: app\_lookup\_by\_app\_id”,

> ```
> "code": 400,
> 
> ```
