# SQL Connection Bitami 2.0.1

**URL:** <https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688>\
**Category:** Connecting to SQL\
**Created:** [October 30, 2015, 2:46pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688 "2015-10-30T14:46:22Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![cmthomps](https://avatars.discourse-cdn.com/v4/letter/c/c2a13f/32.png) [@cmthomps](https://community.dreamfactory.com/u/cmthomps)\
**Post date:** [October 30, 2015, 2:46pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/1 "2015-10-30T14:46:22Z")

</div>

Just stood up a new bitnami server with 2.0.1 installed. I currently have two VMs. One with 2.0.0 and one with 2.0.1. The 2.0.0 version is able to connect to a remote sql server database. The 2.0.1 version is not. The only difference I can see is that in the configuration of the service for 2.0.0 there is a driver selection for MS SQL Server/Sybase (which is what works). In 2.0.1, there is only a selection that says “SQL Server”. Do I need to install another driver on 2.0.1 to get SQL to work?

Thanks,  
Craig

---

<div class="post-metadata">

**Author:** ![jeffreystables](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/jeffreystables/32/173_2.png) [@jeffreystables](https://community.dreamfactory.com/u/jeffreystables)\
**Post date:** [October 30, 2015, 2:57pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/2 "2015-10-30T14:57:42Z")

</div>

Are you using the dblib driver to connect to SQL Server from Linux/Mac or the sqlsrv driver to connect to SQL Server from Windows?

---

<div class="post-metadata">

**Author:** ![cmthomps](https://avatars.discourse-cdn.com/v4/letter/c/c2a13f/32.png) [@cmthomps](https://community.dreamfactory.com/u/cmthomps)\
**Post date:** [October 30, 2015, 3:05pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/3 "2015-10-30T15:05:55Z")

</div>

Trying to connect to a windows box running sql from bitnami on ubuntu. The same connection string works on my 2.0.0 VM. This is the error I’m seeing in the bitnami log.

H01071: Got error ‘PHP message: REST Exception #500 \> Failed to connect to database.\nConnection failed to open the DB connection: SQLSTATE[01002] Adaptive Server connection failed (severity 9)\n’, referer: [http://192.168.0.109/dreamfactory/dist/index.html](http://192.168.0.109/dreamfactory/dist/index.html)

 ![](https://canada1.discourse-cdn.com/flex035/uploads/dreamfactory/original/1X/2a46cae31c2a2371f04f8e8eb207da73feca9872.png)

---

<div class="post-metadata">

**Author:** ![Im\_PJ](https://avatars.discourse-cdn.com/v4/letter/i/59ef9b/32.png) [@Im\_PJ](https://community.dreamfactory.com/u/Im_PJ)\
**Post date:** [October 31, 2015, 3:16am UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/4 "2015-10-31T03:16:40Z")

</div>

I also tried connecting to sql server from DF2.0.1 on windows box but getting error `Required extension or module 'sqlsrv' is not installed or loaded`

---

<div class="post-metadata">

**Author:** ![formerstaff](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/formerstaff/32/1133_2.png) [@formerstaff](https://community.dreamfactory.com/u/formerstaff)\
**Post date:** [November 2, 2015, 1:59pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/5 "2015-11-02T13:59:48Z")

</div>

@Im_PJ that’s actually a different issue than the one originally reported in this thread. You need to install the Micosoft sqlsrv php drivers. Details on that are here: [https://github.com/dreamfactorysoftware/dsp-core/wiki/SQL-Database-Services#sqlsrv](https://github.com/dreamfactorysoftware/dsp-core/wiki/SQL-Database-Services#sqlsrv)

---

<div class="post-metadata">

**Author:** ![formerstaff](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/formerstaff/32/1133_2.png) [@formerstaff](https://community.dreamfactory.com/u/formerstaff)\
**Post date:** [November 2, 2015, 2:01pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/6 "2015-11-02T14:01:17Z")

</div>

@cmthomps can you share the contents of your freetds.conf file?

---

<div class="post-metadata">

**Author:** ![cmthomps](https://avatars.discourse-cdn.com/v4/letter/c/c2a13f/32.png) [@cmthomps](https://community.dreamfactory.com/u/cmthomps)\
**Post date:** [November 2, 2015, 2:25pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/7 "2015-11-02T14:25:13Z")

</div>

Here is the contents of my freetds.conf file:

```

# $Id: freetds.conf,v 1.12 2007/12/25 06:02:36 jklowden Exp $
#
# This file is installed by FreeTDS if no file by the same 
# name is found in the installation directory.  
#
# For information about the layout of this file and its settings, 
# see the freetds.conf manpage "man freetds.conf".  

# Global settings are overridden by those in a database
# server specific section
[global]
        # TDS protocol version
;	tds version = 4.2

	# Whether to write a TDSDUMP file for diagnostic purposes
	# (setting this to /tmp is insecure on a multi-user system)
;	dump file = /tmp/freetds.log
;	debug flags = 0xffff

	# Command and connection timeouts
;	timeout = 10

;	connect timeout = 10
	
	# If you get out-of-memory errors, it may mean that your client
	# is trying to allocate a huge buffer for a TEXT field.  
	# Try setting 'text size' to a more reasonable limit 
	#text size = 20971520

# A typical Sybase server
[egServer50]
	host = symachine.domain.com
	port = 5000
	tds version = 5.0

# A typical Microsoft server
[egServer70]
	host = ntmachine.domain.com
	port = 1433
	tds version = 7.0

```

---

<div class="post-metadata">

**Author:** ![cmthomps](https://avatars.discourse-cdn.com/v4/letter/c/c2a13f/32.png) [@cmthomps](https://community.dreamfactory.com/u/cmthomps)\
**Post date:** [November 2, 2015, 3:05pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/8 "2015-11-02T15:05:45Z")

</div>

So I just retested. I’m able to connect to my SQL box now. I’m not entirely sure what changed. Sorry if I created a fire drill.

---

<div class="post-metadata">

**Author:** ![formerstaff](https://yyz1.discourse-cdn.com/flex035/user_avatar/community.dreamfactory.com/formerstaff/32/1133_2.png) [@formerstaff](https://community.dreamfactory.com/u/formerstaff)\
**Post date:** [November 2, 2015, 3:14pm UTC](https://community.dreamfactory.com/t/sql-connection-bitami-2-0-1/1688/9 "2015-11-02T15:14:28Z")

</div>

No worries on our end. Glad it’s working for you!
