# \* System error building event map for service 'files'. Bitnami DF 2.7.0-1

**URL:** <https://community.dreamfactory.com/t/system-error-building-event-map-for-service-files-bitnami-df-2-7-0-1/3899>\
**Category:** uncategorized\
**Created:** [June 17, 2017, 8:35pm UTC](https://community.dreamfactory.com/t/system-error-building-event-map-for-service-files-bitnami-df-2-7-0-1/3899 "2017-06-17T20:35:37Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![m\_menon](https://avatars.discourse-cdn.com/v4/letter/m/85f322/32.png) [@m\_menon](https://community.dreamfactory.com/u/m_menon)\
**Post date:** [June 17, 2017, 8:35pm UTC](https://community.dreamfactory.com/t/system-error-building-event-map-for-service-files-bitnami-df-2-7-0-1/3899/1 "2017-06-17T20:35:37Z")

</div>

[2017-06-17 19:40:43] local.ERROR: \* System error building event map for service ‘files’.  
mkdir(): Permission denied

Would anyone know why the above could be happening? I have given whatever permissions are necessary to the  
`/opt/dreamfactory-2.7.0-1/apps/dreamfactory/htdocs/storage/app` folder as this is where the file storage is.

It’s Bitnami Dreamfactory 2.7.0-1 ( the latest one as on date ). The below 2 steps I have already executed  
sudo chown -R daemon:daemon storage/ bootstrap/cache/  
sudo chmod -R 2775 storage/ bootstrap/cache/

Any pointers? Thanks

---

<div class="post-metadata">

**Author:** ![m\_menon](https://avatars.discourse-cdn.com/v4/letter/m/85f322/32.png) [@m\_menon](https://community.dreamfactory.com/u/m_menon)\
**Post date:** [June 21, 2017, 12:51pm UTC](https://community.dreamfactory.com/t/system-error-building-event-map-for-service-files-bitnami-df-2-7-0-1/3899/2 "2017-06-21T12:51:49Z")

</div>

I got a reply to this on the other forum. Thanks Schoel for that. Really appreciate it. Here’s the [link](https://community.bitnami.com/t/system-error-building-event-map-for-service-files/49984/6?u=ripplingwater75) and the solution from [Schoel](https://community.bitnami.com/t/system-error-building-event-map-for-service-files/49984/6?u=ripplingwater75)

> I was having the same issue and it turns out that DF tries to access the app sub-directory to whatever PWD is. This actually should fail, although DF should not try to do this.

> So, to work around this issue, you can configure the files service and set root folder to either an absolute path or to local which will tell DF to use the app directory inside the storage directory

Cheers,  
M.M
