About the Lookup Keys

Continuing the discussion from Amazon / Bitnami / Dreamfactory / Mongo Setup:

See this thread on setting up Lookup Keys. Currently experiencing a problem getting the lookup keys to authenticate the Mongo DB server

There is a bug that prevents you from using lookups for credentials in services. This bug is resolved in the forthcoming release (in ~ 2 weeks)

Okay, figured after a couple hours hammering my keyboard and abusing Google time to reach out for a lifeline.

Connecting to external MongoDb (Amazon VPC)

Setting up the service and roles.

In my service, I can create a role and connect no problem with:


But when I try to enter Lookup Keys in the role to replace the mymongousername:mymongopassword I can no longer connect.

I set up my service like this:


and in my user role I set up

KEY: m_username VALUE: mymongousername PRVATE
KEY: m_password VALUE: mymongopassword PRIVATE

I get a response:

Unexpected MongoDb Service Exception:
Failed to connect to: SASL Authentication failed on database 'mymongodb': Authentication failed.

I tried variants of username/password curly brackets etc but no luck. I revert back to original service setup with mongodb://mymongousername:mymongopassword@ and connect again no problem.

Any help?

Sorry if this is confusing. I tried to merge the topics. See my reply 2 posts up.