Access to BLOB type (MySQL)

I have a pretty default install of dreamfactory, and the dropdown list of types in the schema section does not include blobs. I have tried using strings/text type, then setting database type to BLOB but it reverts to a dreamfactory type of string, and DB type of text, with 0 length.

Does blob normally appear in the dropdown list as a type? Or am I supposed to enter blob as a database type? I have also tried with varbinary type, but that tops out at 63k length, which is understandable.

For blob, it looks like you’ll want to use binary as the type.

A couple of thoughts

Is the 64K limit dreamfactory or the database?

in the past i have used base64 strings because binary can corrupt xml / json parsing

Another solution is to use file storage and store the object name in the database

I have tried changing the datatype directly in the database, and dreamfactory did not mind. Everything worked, and I could put >65k of text in a MEDIUMTEXT field.

AFAIK, there is no field that can take >65k of data from the schema-editor in dreamfactory yet.