Adding Virtual Relationships broken in DF 2.7.0?

I installed a fresh new version of DF 2.7 using the manual Github Method and I tried to add some tables with some Virtual Relationships but i could not select any fields, reference service etc. in the Schema configuratior.


If I add an V R via json, it get’s created but editing it shows exactly the same. Just the ‘Select Field’ list items.

Can anyone confirm that?

@tizzyapunkt this issue has been filed with the team and should be fixed in the forthcoming release. In the interim Virtual Foreign Keys can be created programmatically via the API. Schema operations that can be done via the UI can be done programmatically via the API. For the full detail on the schema resource and how it can be viewed and managed via the API go here.

Alternatively, if you’d like to checkout the git tags for a previous version where this worked, looking at 2.6.0 and earlier iterations this should be working.

1 Like

As the scheme editor seems to be broken in 2.8 (mentioned here), I needed to do some scheme stuff in 2.7 again and noticed, that updating virtual relationships via API does not work either in 2.7. Creating relationship via API works though.