AWS Market and upgrades

Hi all… new to dreamfactory… and overall LOVING it… I am working with an amazon web services EC2 account. I originally installed dreamfactory to my AWS via bitnami’s site, but it looked like a bad install as it kept giving me a blank screen when i went to enter my dashboard. Anyway, since then i got it working by installing directly from the AWS Market. It said that it was through bitnami but the version that got installed was 1.4.0-2 while the bitnami version was 1.5.something? I have been bouncing questions regarding users to Mark Stephens of Dreamfactory and he has been great at answering my questions. But it appears i need to update dream factory and i don’t want to loose the work i have done. That said, i can’t seem to find a way to update the instance via AWS. anyone else on AWS know how to check for updates?


whoops… nevermind… just found it under config!

But after installing an upgrade and waiting for the AWS status checks to clear, the launchpad is now just a blank screen… do i need to role back? anyone have this problem?

Hi Erik, not sure why that happened. I gave Mark a heads up to help you troubleshoot the problem.

Ben, thanks… mark has been quite the trooper putting up with my endless questions. I tried doing a reboot of the service, but that didn’t seem to help… don’t know if the the upgrade just takes a while? its been almost 45minutes… I made a snapshot before i did the update, but restoring the snapshot from aws is not intuitive and i cant figure out how to do that.

This morning i created a new instance on my aws of DSP 1.4.3. all i did was change the admin user credentials and then went to config and clicked upgrade to 1.5.9. The update is giving me the same issue…
“server down or misconfigured”

Again, started a new instance… this time only going to the lowest available upgrade via the config tab :1.5.0 from 1.4.x
still same issue… it gets to : and i get an error… im totally bummed seems like i am stuck with 1.4.x and won’t be able to use any of the wonderful things you folks are working on… So frustrated

Just tried another approach. created a clean install from of 1.5.9 thinking maybe something is wrong with the update… picked EBS ami-85c4b2b5 and selected my region… AWS shortly shows the instance as running but when i try to go to the launcher i get a ‘page not found’ i looked at the log to and noticed it gets passed the ssh finger prints and then stops… never shows the password logs needed to log in the first time…

This makes me very sad… 1.4.x installs fine on aws but 1.5x fails every time no matter how i try to do it.

UPDATE after creating a new instance of 1.5.9 that was showing up as missing, i went back to my ‘ec2 instances running’ and changed the security group to “dreamfactory…” it was set to “launch-wizard”

i then tried again… i got to the dashboard and was able to log in as password bitnami . note it did not show a random generated password as stated in aws documentation which is why i tried the standard bitnami… its up and running 1.5.9 hope this helps others…

Hey Erik, sorry for the ordeal get 1.5.9 up and running. Thanks for sharing what you did to get it working. We’re working on a lot more short tutorials including installation guides. Hopefully this will help others in the future!

Its back… went to upgrade this morning from 1.5.9 to 1.6.3 via the config button… and now my AWS EC2 instance shows that it is running again… but when i go to log in i just get a blank screen!!! So scared~

So, it looks like there is an issue when performing an upgrade on a Bitnami AWS instance from 1.5.9 to 1.6.3. Until there is another fix, please do the following to allow for a successful upgrade:

cd /opt/bitnami/apps/dreamfactory/htdocs

sudo ./scripts/ 

-vsudo chgrp 

-R daemon *sudo chgrp 

-R daemon .*

Reload frame in browser.


1 Like

Thanks for posting this fix, also had similar issue and running the installer again solved it.