Could not find a service for

New install 2.3.0 when I do rest api I keep getting this error
any idea what am I doing wrong ?

1 Like

Hi @Vinod_Hum the error does not appear in this post. Also, details on DreamFactory version and installation details would be helpful.

Can you send more details over?


Hi Alex, I’m getting this issue with a new installation of 2.3.0-2 on windows 10.

Here is the object I’m getting back from df when I try post a login:
{“error”:{“context”:null,“message”:“Could not find a service for {“email”:“”,“password”:”**********",“remember_me”:false}",“code”:404}}

I tried the login from swagger and it worked. Checking fiddler, a different api key was being given and a session token was provided. I can’t provide a session token as I don’t have one yet.

Any help would be great.

Is there any additional information that would be helpful, please let me know.


1 Like

Is this the whole error message?
Because the message looks like you somehow sent your payload as part of the endpoint URL. That would definitely cause a service not found error.
If this is not the whole error, perhaps you could post it, as well as the full API call you are making and how you’re making it.

1 Like

@dougal I had a similar error after upgrading my Bitnami instance on AWS from 2.2 to 2.3.
Try adding the following headers to your http requests and see if it helps? That was what solved it for me.

'Content-Type': 'application/json'
1 Like

I think @dipoM is right about this one.

1 Like

Many thanks guys, that sorted the issue.

1 Like