Failed to launch service "df"


I just installed DreamFactory as per the steps provided on the GitHub page.

Even after completing all the steps. When I try to open the admin page, the following error is shown:

"Failed to launch service "df": Service not found"

How can I resolve this, any idea?

@tejas hard to say from the error message alone. Could you provide some more information about your instance? Some useful information would be the type of web server used during installation and operating system. Additionally, DreamFactory does some logging here (may differ depending on your environment): {install directory}/storage/logs/dreamfactory.log

These logs might reveal some useful information in helping us identify the culprit preventing your instance from opening to the admin. page.

Hey @mattschaer,

The logs contain the following the error:

production.ALERT: Could not get cors config from DB - SQLSTATE[HY000] 
[1045] Access denied for user 'forge'@'localhost' (using password: NO) 

Is there any additional setup needed?

@tejas Assuming you installed from GitHub could you tell me what is the system database you are using? Is it MySQL or SQLite? The error message you are receiving can be better interpreted with some more detailed information about the environment in which you’ve installed your DreamFactory instance.

Hi @mattschaer,

System database is MySQL. Database is Migrated & Seeded using the setup command.

The environment details are CentOS, PHP 5.5+, MySQL 5.6.+
Any other details needed?

Even DEBUGGING is set to true.

Still the error message is same: "Failed to launch service “df”: Service not found"
One thing to notice is that, I have “df” in my URL. Eg- hostname/df/dreamfactory/public.

Is this “df” in the URL is causing the issue?

DreamFactory cannot be run as a subfolder of a site. The DreamFactory public directory must be the root of the site in order for it to function properly. You should set up a separate virtual host for your DreamFactory installation.

Hi @drewpearce,

Thank You for the update. I created a sub domain & directed it to the public folder of the DreamFactory.

Now just one issue remains is that I get the following error when I open the home page:

Failed to load resource: the server responded with a status of 400 (Bad Request)

Login page form is not loaded as it normally works on local.
Is it because of CORS? DO we need to set something on server?

check you dreamfactory log and your apache log to see what specific errors are reported there.

just guessing, but it could be a permissions issue. Make sure that the Apache user (www-data on Ubuntu/debian systems) has read & write access to the storage/ and bootstrap/cache/ directories.

Hey @drewpearce,

Checked the logs. Also checked the AJAX call which is made to get the ENVIRONMENT details.
This AJAX call is failing in the index page of Admin Console.

Entered the URL in the browser - It worked.
Repeated the AJAX call without headers using POSTMAN - It worked.
Repeated the AJAX call with headers by adding X-DreamFactory-API-Key using POSTMAN - Error.

Error message:
> “message”: “Unknown relationship: app_lookup_by_app_id”,

    "code": 400,