NodeJS throwing error code 127

Running Dreamfactory on CentOS 7:

I have an issue with server side scripting where running NodeJS script throws an error, “Executed command returned with error code: 127”. Creating a service with NodeJS is running fine but when I run a post process in NodeJS script to customize a native api, it throws an error code 127.

Enabling the DEBUG mode seems not capturing details of this error. Is there anyway that I can check details of this error?

1 Like

get.pre_process is running fine. However if I run the same nodejs code in get.post_process, it throws an error 127.

Exit code 127 indicates a ‘command not found error’.

could you try running hello.js separately? I suspect the sudo is causing problems since the child process for hello.js won’t also start under sudo. Try something like:

~/nodejs/node-inspector sudo node_g --debug test/hello.js &

~/nodejs/node-inspector sudo node bin/inspector.js

If that doesn’t work could you provide more details on your environment and distro?

Bhanu Prasad

Both commands running under sudo seems not working.

The environment is running under:
CentOS Linux release 7.4.1708 (Core)
NodeJS v8.7.0

Same here… when i try to update with payload more than 4000 rows of records using nodejs in dreamfactory, it return error code 127. but less than 2000 rows of records it is working fine. What’s the problem?

Environment running under:
Ubuntu 14.04.5 LTS (GNU/Linux 4.4.0-63-generic x86_64)
Dreamfactory running inside docker
NodeJS version inside dreamfactory v6.11.4

The same data right away run in robomongo, it is able to run without errors.

Hello @misterbaanu and @Anson_Hwa,

There was an update to our scripting logic that affects Node(and Python). It was updated January 16th in our DF-Core module. Here is the snippet that was added in the commit:


If you upgrade your DreamFactory install to at least 2.11 you should be solid.

Here is the wiki link: