Token refresh not working

Hi there!

I’m having an issue when refreshing the JWT token on my dreamfactory 2.11.1 bitnami installation.

I’ll just get an HTTP 401 “Token has expired: …” when I try to refresh it after the JWT time to live and before the Refresh time to live. Refreshing within the JWT time to live works, but that’s for sure not the right way to go…
Did the tutorial from here:

my config seems to be ok, when I do GET /api/v2/system/environment as admin I see:
“df_jwt_refresh_ttl”: “20160”,
“df_jwt_ttl”: “60”,

My steps to try to refresh the token:

POST ‘/api/v2/user/session’ with payload ‘{“email”:“XXX”,“password”:“XXX”,“remember_me”:true}’

PUT ‘/api/v2/user/session’ with empty payload and the headers Content-Type, X-DreamFactory-Api-Key, X-DreamFactory-Session-Token set.
tried PUT ‘/api/v2/user/session?session_token=TOKEN’ too.
but I still get a HTTP 401 error saying “Token has expired: Session expired. Please refresh your token (if still within refresh window) or re-login.”

Thank you in Advance for your suggestions what I could do.

@qwarl is the user you are trying to refresh the token for an admin or a regular user?

Hi erik. thank you for your suggestion.
I tried both on the admin endpoint and user endpoint now, none works for me. I’d just need it for normal users.

I also facing the same issue as qwarl
My configuration is as follows


Please suggest.