Email Config Issues

I’m embarrassed I’m having issues configuring email…

I got the gmail settings from here:

I plugged them into the Email Service’s Configuration…

Provider: SMTP
Port: 587
Security: TLS
Password: mygmailaccountpassword

And for parameters…

from_name: Me
reply_to_name: Me

I look for the “Test” button.

I then run this…

echo "{ \
      \"to\": [
          \"name\": \"A Name\",
          \"email\": \"\"
      \"subject\": \"The Subject\", \
      \"from_name\": \"Me\", \
      \"from_email\": \"*myusername*\" \
    }" | curl --insecure -X POST -d @- https://ec2-*yada-yada* -H 'X-DreamFactory-Application-Name: spma'

And then this is what I get…

{"error":[{"context":null,"message":"Failed to send to the following addresses:Array\n(\n    [0] =>\n)\n","code":500}]}

In the above paste-onto-the-Internet, I’ve substituted out the actual email addresses. I don’t think I have a problem with the address. I substituted with a malformed email address and it gives me an “Invalid email” message. The error message I get hints that the problem is with the address, not with the server config, connectivity, SMTP authentication, etc.

I’m curious what that greater-than is in the error message. Doesn’t look too symmetric and I have no idea where it came from or what it means.

Yes, “failed to send” but why?

In Config, I’ve allowed Guest Users and I assign them to my guest role and the guest role is set up as having permission to POST to the Email Service, plus I don’t get any sort of HTTP permissions-related response code. I don’t think it’s DSP security as such.

And I changed the Email Service’s configuration to try port 80 on It produces the same ambiguous error message.

Is there caching going on of config that it’s not running the current config after I update it?

I’m running on AWS. Is there a network routing issue where it can’t get to

I feel like a noob asking this question.

But I’m stuck with the indescript error message and DSP’s hiding of the cause.



There have been a couple related issues on this, especially geared towards AWS. You can have a look here, as I continue to test and debug the issue.

AWS uses an Ubuntu OS. In this case, you’d be best following these instructions on the Wiki to setup your service.

This is located on our email services wiki page

It is also important to mention that AWS sometimes won’t allow a port to be opened unless specified - so port 25 (this is the typical default email port) is blocked initially.

Have a look at this and it should at least point you in the right direction.

All of this worked up until this point, though, correct?


I do that.

  1. Switch it to Server Command.
  2. I put in the fully specified path to the sendmail command with switches.
  3. I hit “Update.”

DSP does this wicked cool HTML5 animation thingy with:

Checkmark! Services
Updated Succesfully.

The pop-up beautifully fades away.

And the DSP LauchPad 1.7.8 shifts context (on its own none-the-less).

I click on, again to reset context, Email Service.

And DSP shows the Provider as SMTP, not what I’ve just set it to.

And I repeat several times this path in what seems to be leading me into an infinite loop of reconfigurations until I hit loop break in my mind and post this response.

And yes, with trying to test again, with what seems to be my failings at reconfigurations, I do indeed get the same opaque message that the server “Failed to send to the following addresses”.

There’s a problem in 1.8.1 and older where email services configured for SMTP are attempting to call sendmail instead. I tested this on an AWS Bitnami install. On top of that, sendmail was failing because the following line in php.ini was commented out. To get sendmail working uncomment this line (or similar) in php.ini and restart apache.

sendmail_path = "env -i /usr/sbin/sendmail -t -i"

The fix for SMTP will be in the next release 1.8.2 due out this week. The problem with email type not sticking in the admin console will also be fixed.

Hello this issue is still not fixed because i get the error:

“message”:“Failed to send to the following addresses:Array\n(\n [0] =>\n)\n”,

DreamFactory Services Platform Version: 1.9.1

This is still not working dude.

Are you using server command, server default, or SMTP? If SMTP, there was an issue with SMTP credentials in 1.9.1 that is resolved in the current version, 1.9.2.

Jeffrey, are these the correct versions? I brought up this post months ago and didn’t use DSP for a while because of this issue. I’m running DreamFactory Services Platform Version: 1.9.1 and SMTP email seems to work for me after getting some help to get it set up.

Hi @skipatrolmobile, actually you did install 1.9.1 but while working with support we upgraded you with the email fix that was included in 1.9.2. I believe the 1.9.2 update is still necessary to resolve the email issue you experienced initially.

Thanks. Glad to get this fixed. Everything’s going well now.

1 Like