Sendmail issue - Gives 200 response but no email

I have sendmail configured with Amazon SES and it is working fine. The problem is that the dreamfactory is not sending email using sendmail. I have tried to make 2 services, one using default server and one with server command /usr/sbin/sendmail -bs. After sending using swagger, it give the message

“count”: 1

but the message doesnt actually get sent. Please help.


Need more specifics here. Port blocks? Aws is restrictive about this. This is your issue. I am creating a guide to go with AWS users that shows how to allow this, amongst other features when the new release is out!


  • Mark

I really dont know what the issue is. The sendmail was configured with Amazon SES.

I tried on duplicate server with Postfix and that works nicely, thus going with Postfix instead of Sendmail.

Okay - I’m looking into Sendmail myself and plan to have a step-by-step guide coming out around the same time as the new release.

You’ve yet demonstrated another great example of the versatility of our Platform: plug-in-play compatibilities for a variety of services!

Thanks, keep us all in the loop on your progress.

  • Mark

Frankly Mark, your platform is awesome. Saved us a whole bunch of work and money. Also, I would suggest that you suggest people to use Postfix instead specially if they are planning to integrate with Amazon SES. Its super easy to configure and works beautifully with Dreamfactory.

I do have another query, can we store Database Service Username and password as a global key? If yes, then how do we implement. Tried alot of combinations but were unsuccessful.

One more thing, I dont know about other people but we are using Dreamfactory primarily for APP API’s. Thus, all users will have no access to the admin site. The problem is that currently there is no way of protecting the admin site from brute force attack without implementing Apache IP restrictions. Thus, there should be an option to enable Captcha or TOTP for the Login to the site. Just a small suggestion if possible.


Good idea on Captcha for site login, thanks. Will capture that as a feature request!

Sorry I have to use this old thread - but I’m currently facing the exact same issue. The command is configures as “mail -t” (which works using it via SSH) and it gives me a “count:1”-response, but no actual emails are sent / nothing shows up in exim4’s log.

Now I’ve tried using postfix as well - works from SSH, doesn’t work from DSP (again, count = 1 but no mail or log in /var/log/mail.log)… =(

Edit: Sorry for the confusion, I’ve now got it up and running (Debian 7):

  1. Configure postfix
  2. DSP-Service: Use server-command “/usr/sbin/sendmail -bs”
  3. Make sure both the recipient and the sender are in the allowed list of SES unless you’re already productive w/ SES
  4. Make sure the ports are open (I use 587)
  5. When testing, use/check tail -f /var/log/mail.log
1 Like

Glad you got it working, @BeerBeer. Thanks for posting your update so the community can benefit from your experience.