Error in MySQL syntax when accessing API

I created connection to existing MySQL database and headed out to API Docs tab to test it.
Apparently, requests fail with the following message:

“SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘.app’ at line 1 (SQL: SHOW FULL TABLES FROM”,

The syntax is indeed invalid, why does the generated code contain .app?
Please note that /my_db_name endpoint is working fine, but all other endpoints are giving the same error.

what is your service configuration?

best guess is that because this is the root user it has access to some items that DF doesn’t understand. Did you check the “default schema only” box? I’d definitely recommend that.

1 Like

Thank you, enabling “default schema only” box resolved the issue.

1 Like

It eventually solved mine, but i had to recreate a Service. There seems to be some caching going on that prevents changes to a created service from flowing through.