Getting "CDbConnection failed to open the DB connection" when connecting to MySQL

I have been using the Dreamfactory Developer DSP with no problems connecting to this MySQL database. I created a new Bitnami instance on Google cloud and now am getting an error in the log:
REST Exception #500 > Failed to launch service “interviewly”: CDbConnection failed to open the DB connection. {“host”:"",“request_uri”:"/rest//_schema?fields=name&refresh=true",“source_ip”:“”,“sapi_name”:“fpm-fcgi”}
[2015-09-06 09:29:53][app][ERROR ] SQLSTATE[HY000] [1044] Access denied for user ‘’@’%’ to database ‘’

I’ve tried adding the port number to the mySQL connection string with no luck. The connection strings between the two instances (DreamFactory DSP and Bitnami are identical besides the port number)

One of the posts said to make sure that the MySQL drivers are updated on the bitnami instance but I can’t find info on how to do this.

Another update:
Referenced from this article: Can't connect to Remote MySQL server
I found the php.ini file to confirm the was uncommented and it is.

For anyone searching for it: the php.ini is located in: ~/stack/php/etc and the extensions is in ~/stack/php/lib/php/extensions

This is the error returned from your MySQL server. It cannot be related to drivers or your connection string, because otherwise you wouldn’t be connected to MySQL and it wouldn’t be able to send back this error. This is clearly an authentication or credentials issue. Have you confirmed that you’ve input the correct user name and password into the service definition in the DreamFactory admin console? Have you confirmed that this user has access to the database you’re connecting to?

Yes - the user had access and the password was correct. I got the password value by using the following code to get the password value from the screen: $(".ng-pristine")[7].value then just to make sure that it was correct I updated that user password in mysql. Still no-go. I ended up deleting the service and re-adding same user and password values and now it’s magically working. In my initial service setup I left some of the fields blank. Not sure if that was the problem but now it’s working! Thanks for pointing me the right direction!

BTW - I love DreamFactory. Your BAAS is AWESOME!

1 Like