Mysql Remote Not Connecting (Ubuntu 14 git/bitnami)

I created a droplet in my digitalocean account and installed all the needed packages as listed in the tutorial for installation under ubuntu.
The dreamfactory works ok with the native db, all working. But any remote server that i tryed to connect did not worked.

“error”: [
“context”: null,
“message”: “Failed to launch service “tsbr”: CDbConnection failed to open the DB connection.”,
“code”: 500

I know that the issue its not in the servers where the db are cause i’ve tested the windows version of dreamfactory and the remote sql function worked fine.

This is the only error that i got during the install:

Those errors are normal during installation. They are actually part of the Pear update and installation and do not represent any DSP dependencies.

To get better error messaging on your failed connection, you will want to look at your log file. In a Bitnami install, logs are located in the …htdocs/log directory. In a manual install, the log file location will be determined by how you configured your Apache vhost.

I looked into my logs and there’s nothing logged there. Just the access errors that i got before i had the right apache2 configuration (cause the apache version that im using its > 2.3)

I will try the bitnami installer before we go on trying to find the error here. Thanks for the response till now.

The screenshot is tiny, but those do not appear to be DSP log entries. Are you sure you checked the DSP’s logs and not Apache’s logs?

I installed with the bitnami installer and got the same error. Where is located the DF log in the bitnami install?

{Bitnami Install Directory}\apps\dreamfactory\htdocs\log\

1 Like

[2015-05-05 08:26:51][app][ERROR ] REST Exception #500 > Failed to launch service “service_name”: CDbConnection failed to open the DB connection. {“host”:“ip of my droplet”,“request_uri”:"/rest/service_name",“source_ip”:“ip of my dsl connection”,“sapi_name”:"ap$
[2015-05-05 08:26:51][app][ERROR ] SQLSTATE[HY000] [2002] Connection timed out

I changed my droplet ip, my local dsl connection ip and service name for privacy.

Please confirm that your DB server is accepting connections on the IP and port you have specified. E.g., from your DSP server,

$ telnet 3306


$ telnet 3306

This will confirm the connection is being accepted from your DSP. The log error indicates the remote server is not listening or not accepting the connection.

1 Like

I tried and got time out. I think this is the problem. Even with the wildcard for mysql remote, i could not connect. I think that may exist some firewall exception for foreign ip that i currently dont have access to manage.

Thank you for the help, i will just confirm that this was the problem before close this issue.