Local Wamp installation from GitHub: blank page after user registration

Hi everyone,
I installed DreamFactory directly on my WAMP stack from GitHub.
I found another post on this forum that exactly describes what I’m experiencing (“New install shows blank pages after creating the admin userGitHub Installers”); in this thread the culprit was an old PHP version, but my PHP version is 5.5.12
How can I troubleshoot this issue?

You’ll want to check your Apache logs and your DreamFactory logs. That should tell you where the problem is.
This symptom can be triggered by many root causes, but one common one is incorrect permissions on some key folder locations in the install. If that’s the case it will definitely be in the logs, something like “cloud not open location” or “access denied” for a certain folder location.

Hi drewpearce and thanks for your support.
It seems that my logs are errors free

Chunk of apache_error.log:

[Fri Sep 18 09:23:30.690256 2015] [mpm_winnt:notice] [pid 5880:tid 384] AH00455: Apache/2.4.9 (Win64) PHP/5.5.12 configured -- resuming normal operations
[Fri Sep 18 09:23:30.699257 2015] [mpm_winnt:notice] [pid 5880:tid 384] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:42:59
[Fri Sep 18 09:23:30.699257 2015] [core:notice] [pid 5880:tid 384] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.9\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.9'
[Fri Sep 18 09:23:30.701257 2015] [mpm_winnt:notice] [pid 5880:tid 384] AH00418: Parent: Created child process 4480
[Fri Sep 18 09:23:31.380296 2015] [mpm_winnt:notice] [pid 4480:tid 300] AH00354: Child: Starting 64 worker threads.

My dreamfactory log didn’t report any entry today; the last entry was:

[2015-09-17 09:06:41][app][ERROR    ] SQLSTATE[HY000] [1045] Access denied for user 'dsp_user'@'localhost' (using password: YES)  

I fixed this problem yesterday.
I have a problem with page redirection; when I ask for http://localhost/dsp/web (Dreamfactory install folder) the web server redirects to http://localhost/dreamfactory/dist/index.html with 404 error.

If I manually write the following URL: http://localhost/dsp/web/dreamfactory/dist/index.html the browser shows me the famous blank page.

Ah, that would explain it.
DreamFactory needs to be at the root of a virtualhost, not in a subdirectory. So if you intend to host multiple sites/application on this apache install, you’ll need to give it its own vhost config.

If it is the only thing on the box, you need to adjust the vhost config to point the web folder as the document root.

Hi drewpearce and thanks for your answer.
I’m not an experienced Apache user, so I have to learn how to properly configure a virtual host for my Dreamfactory install. I’ll keep you updated.

There are many WAMP tutorials out there for virtual hosts. Just be sure to point the document root the web folder
(if you’re following along with the wiki instructions, this would be C:\dsp\web)

Hi drewpearce!
Finally, I configured the virtual host and now my local setup is running.
Thanks again.


Hi Drew,
I am using wamp with php 5.5. and i tried to do local setup with vhost.i downloaded this full zip

and tried to point to this dip extracted content. i am getting directory listing. as mentioned in your previous comments i dint find any web folder to point my vhost. PLease me in this setup locally.

This thread is for the legacy product (version 1.x)
Please consult the installation instructions here: http://wiki.dreamfactory.com/DreamFactory/Installation#GitHub
and in the ReadMe: https://github.com/dreamfactorysoftware/dreamfactory/blob/master/README.md