New install shows blank pages after creating the admin user

Hi All,
I tried installing Dreamfactory on ubuntu 12.04 from github using this guide: The install completes fine and when I launch the site, I get a screen to create an admin user. I submit the form and after a few minutes I get a screen asking if I want free support. I click no and the screen seems to hang for a few more minutes, then I get a blank, all-white page after being redirected to “/dreamfactory/dist/index.html”. I am behind a proxy. Sounds like that matters.
Any help would be appreciated.

Where I’ve looked:

  • Apache error logs don’t show anything
  • Dreamfactory install log doesn’t show anything other than Apache restarting.
  • Dreamfactory error log shows what is below.

What’ I’ve tried

  • Installing on a brand new VM

  • Following the instructions here: Upgrading from 1.5.9 to 1.6.10 on AWS Bitnami (Several components do upgrade)

  • deleting the .registration file. Creating a new .registration file.

  • Navigating to /launchpad/index.html (I get a 500 error)

  • Restarting apache and mysql and rebooting the server

    2015-02-09 15:26:44][app][INFO ] Building Swagger cache
    [2015-02-09 15:26:44][app][DEBUG ] * Discovered 17 event(s).
    [2015-02-09 15:26:44][app][ERROR ] Use of undefined constant JSON_UNESCAPED_SLASHES - assumed ‘JSON_UNESCAPED_SLASHES’ (/opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Services/SwaggerManager.php:204)
    Stack trace:
    #0 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Events/EventDispatcher.php(207): DreamFactory\Platform\Events\EventDispatcher->checkMappedScripts()
    #1 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Events/EventDispatcher.php(154): DreamFactory\Platform\Events\EventDispatcher->_initializeEventScripting()
    #2 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Yii/Components/PlatformWebApplication.php(1173): DreamFactory\Platform\Events\EventDispatcher->__construct()
    #3 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Utility/Platform.php(633): getDispatcher()
    #4 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Utility/Platform.php(546): getDispatcher()
    #5 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Services/BasePlatformRestService.php(657): trigger()
    #6 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-platform/src/Services/BasePlatformRestService.php(746): DreamFactory\Platfo

    #25 /opt/dreamfactory/platform/vendor/dreamfactory/yii/framework/yiilite.php(1190): DreamFactory\Platform\Yii\Components\PlatformWebApplication->processRequest()
    #26 /opt/dreamfactory/platform/vendor/dreamfactory/lib-php-common-yii/src/Utility/Pii.php(215): DreamFactory\Platform\Yii\Components\PlatformWebApplication->run()
    #27 /opt/dreamfactory/platform/web/index.php(69): run()

What version of PHP are you using?

Well that was easy. I had an old version as the Ubuntu 12.04 repositories didn’t have the latest version. I upgraded to 5.6 thanks to Ondřej’s repository and it’s working.


Glad my hunch was correct. We do depend on PHP 5.4 or higher.