Role not found - 404


Ive tried everything that I could think of, but I am still getting this message when I call the email service via POST.

I setup an AWS SES email service, then Assigned Service Access to that Role. I have also assigned the role to the app.

Now when I use the API_DOCS the email is working fine, but when I use the POST method via POSTMAN etc it shows role not found. I have tried almost everything that I could think of, please help.


Can you send me a screen shot of the role privileges? Please confirm you have allowed for POST. Go to Roles - Access.

A “Role not found” Error means that a role may not be assigned to you for your app.

  • A role could not be determined in order to allow access to the api call.
  • If the call was made with an api key and a session token, then the user does not have a role assigned for this api key, and the api key has no default role.
  • If the call was make with an api key only, then the api key has no default role.
  • Assign the appropriate role in the admin console.

Your error indicates that no role was found. If you have not assigned a default role to your app (associated with your API key) then you will receive this error. If you are providing authentication with a session token, and the authenticated user doesn’t have a role associated with that app (API key) then you will receive this error.

All calls in DreamFactory require an API key. They also require a role that permits access to the resource specified in the call. The role is determined by the user’s user to app to role relationship, if the call included session information, or by checking the default role for the app, if no session info is provided.

A few exceptions:

  • User login and User registration calls do not require a role or API key.
  • Admin sessions do not require an API key. When you use API Docs in the admin console, the system passes the admin session in the background for you.

See wiki documentation here:



After trying and retrying I got frustrated. Deleted the whole thing and started from scratch, and it worked :smile:

Thank you for replying, I think we can close this.


1 Like

Sorry to hear you got frustrated, but I’m glad you stuck to it and were able to get it working!

Keep us updated with what you’re working on @smilesinblues. :slight_smile:


but the root problem still exist right ? deleting and starting from scratch is the real solution ?

What is real / permanent l solution for this.

I found out !!! my service name was not matching . but as the error was about the role I was searching in the role , app , user … but actual problem was from mismatch of custom script service name that’s it.

Suggested improvement to the Dreamfactory team : just put a check if service name matches or not.