Send invite error after adding ssl & custom domain

Today I added an ssl cert to my DreamFactory VM which is a Bitnami installer hosted on Azure. I also changed my FQDN, and then updated the ServerName in etc/postfix/ and /opt/bitnami/apache2/conf/httpd.conf.

All other rest functions are working fine, including my existing email service, except when I try to create a new user with a call to “/system/user?send_invite=true&fields=first_name%2Clast_name” When I do that I get an error: No database entry exists for a user with id ‘’.",“code”:404. The user is created successfully, but no invite email is sent.

This error originates from /opt/bitnami/apps/dreamfactory/htdocs/vendor/dreamfactory/lib-php-common-platform/src/Resources/System/User.php line 139.

I’m not great with php, but was able to determine that both Option::get( $_record, ‘id’ ) and Option::get( $this->_response, ‘id’ ) are not returning an id value in this script.

I’m using DF 1.9 on an Ubuntu VM.

Again, everything was working fine before. Somehow either my FQDN or https changes broke something.

Any help would be much appreciated.


For some reason I needed to specify that the ‘id’ be returned in the call:


This was working without the ‘id’ explicitly being called before I made the noted changes… Anyway, it works now, this is solved.