Start Dreamfactory on system startup (Ubuntu Linux)

Sorry if this thread is already exists but I didn’t found any information about this in documentation or forum.

I’ve installed dreamfactory on my hardware and I want to automatically start all of it’s services on startup. I have added this line to my /etc/rc.local
/home/myUserName/dreamfactory/ start
but it didn’t work for me. Can anyone please help me with this? Thank you a lot!

@Hvojntj Hello! I’m curious when you opened /etc/rc.local in your editor with root permission and add the command. Did you add before the line exit 0 in that file?

Is this a Bitnami installer or was DreamFactory installed from source? I’m wondering if you might not have to add the scripts that start the individual services MySQL, Apache/Nginx etc… to the /etc/rc.local file as well.

Do these services run at startup? Can you check the running processes?

Hello! Thank you for your replay. I’ve opened rc.local using sudo gedit /etc/rc.local and added this line before exit 0. I’ve used Bitnami installer from Resources tab on From what I know from the documentation start command starts all dreamfactory services and works for me great when I use it manually from the terminal. Can you please tell me how should my rc.local file look to make it work? Thank you!

**@Hvojntj You will need to follow these steps:
**-Create a file here: /etc/init.d/bitnami-dreamfactory

**The contents of the file (bitnami-dreamfactory) will be the following (replace usernames and directories with those of your environment):

**# Provides: bitnami-dreamfactory
**# Required-Start: $remote_fs $syslog
**# Required-Stop: $remote_fs syslog **# Default-Start: 2 3 4 5 **# Default-Stop: 0 1 6 **# Short-Description: Start daemon at boot time **# Description: Enable service provided by daemon. **### END INIT INFO **​ **su drew -c "/home/drew/dreamfactory-2.0.2-0/ @"

**-After creating the file you’ll need to pick up at step 3 of these instructions to enable the script:


thank you a lot! Worked for me!

1 Like