Access to user dashboard

After I log in and try to access the dashboard I get this error:
Error CDbException (500)]
CDbConnection failed to open the DB connection.

Is this an error on my end or is something going on behind the scenes?

Thanks

1 Like

is this a SQL Server connection?

thanks,

Mark

let me back up a step. You most likely clicked a tab that loads up services that you’ve created. One of these services (most likely a sql server connection) is not working properly, therefore it shows the error.

I can help you setup this connection properly so that a. it functions as it should and b. you no longer get this error when clicking on other “tabs”

Thanks,

  • Mark

Mark,

I don’t have a SQL service set up though I do have MongoDB service. Though the error was not when I was trying to click a tab it was right after logging in. I’ve tried logging in on another machine and browser from dreamfactory.com and I was getting the same error.

Anyway it was working after 3-4 hours when I tried again from home. I can definitely use your help for configuration though because when trying to create new users under the default role I can’t seem to get access to my services through the UI or the Android API. I just get a 500 response code with the body being null. Or a “server returned an unknown error” on chrome.

Thank you,
Simon

Okay. The error must be a result of your mongo db connection then. This is the only DB Service that you have setup?

“Now, you say after 3-4 hours. it is working” what exactly do you mean by this? You’re no longer getting the error message?

Here are the steps I took to get to the initial error
-I go to dreamfactory.com click sign in at the top right corner
-Enter credentials and sign in
-Click dashboard to launch the dreamfactory webapp dashboard

The website takes a long while to think and then I get to a screen with “Houston we have a problem” with the error code and description. Also yes. After 3-4 hours I tried logging in again and everything loaded up smoothly. And yes, mongo is the only service I have set up. Though everything works fine now, but I just can’t get open registration working, or maybe it’s working as expected? After creating a user with read access to a native app and the mongo service I can’t use those user credentials to log in to see what their dashboard would look like (if they even have one). I get a 500 error code. Same behavior using Java http post and get. The youtube videos don’t really help much when it comes to the android SDK.

Looks like you’ve come into support. Way to take advantage of our free thirty days of support. I’ll be back in touch with you shortly. Thanks,
Mark

I was getting the same error earlier and it was working after 3-4 hours as Simon mentioned. It happened again today at 12:00 am GMT till now.
@Mark would be great if you guys restart the platform or take a look at it.
Thanks in advance.

Have a look now. Hosted system is up and running!

Thanks,

  • Mark

Jaaxxm,

Hey - it’s Mark from Dreamfactory Support. I want to check-in with you quickly to see if you’ve had any occurrence of this problem, again.

Please let me know. And, just to give you a little insight on what’s happening in our world over the next week… we are releasing a new and improved version of the Dreamfactory Service Platform (DSP), planning to be released within a week, possibly even sooner than that!

So, get excited and stay tuned!

Thanks,

  • Mark