Bug: event scripts linked to local file service do not get executed (V2.11.1)

In version 2.10, there is a very useful feature that suggests we can now host event scripts on the file system, by linking the scripts to a file service.

I created a new file service for this purpose, pointed it to a folder under ‘storage’ and gave it a name of a script file. It managed to read the script and show it in the console when I clicked “view latest”. However, the script is never executed, even though it’s saved, set to active. Clearing the cache did not resolve this.
: When saving the script, the loaded script disappears. Not sure if this is by design.

Also, the number of characters allowed in the filename is limited. Suggestion: increase the number of characters allowed and default to the script name as shown in the console. This way, script files can be easily traces back to the relevant endpoint and method.

EDIT: upgraded instance from 2.10 to to 2.11.1, same result. Modified title of this post.

Hi @jps,

What language are you scripting in?


Javascript. Upgraded to 2.12, same result.

At version 2.14 now. Same result. Is this working for anyone?
I need this so we can version control scripts.