Can't get guest users to work [error :403]

I want to enable access to some parts of my App API without any kind of user authentication.

I created a new read only role from the console then in the admin console I allowed guest users access

I keep getting that error

{“error”:[{“context”:null,“message”:“Access to application ‘example-application’ is not provisioned for this user’s role.”,“code”:403}]}

Am I missing something or I have to use authentication even for guest users?

In the role you created for guest users, check the box next to “example-application” and make sure the services you want access to are in the service access list below.

I did that. I can only query rest/db but if i specify the table i keep getting that error.

Did you figure it out? Make sure you grant correct CRUD permissions to the specific table for that role (or set database service access to * for test development). If you’re still having issues, contact and we’ll troubleshoot it with you.

He contacted me on the support line and was able to solve his own issue - we think that it was related to the “-” in his application name, so he potentially found a issue during the process.

Hi, we are facing this same error. Getting 403 error for users but not admin. CORS access set to * and guest users is disabled. Would really appreciate help. Thanks.

Users are able to login but when we do a get, we get the error

“error”: [
“context”: null,
“message”: “Access to application ‘admin’ is not provisioned for this user’s role.”,
“code”: 403

The role has been correctly set. Please help.

Solved. It seems it wont work using the swagger link but works fine using curl and takes a couple of minutes to implement the modifications. Thanks.


This is not a CORS issue but a permissions error. You must configure the role within the admin console to have access to this application. As it is, the app that you’re requesting access to is an admin app. Therefore you must grant user access to the admin app within your admin console.

Again, you can do this through the admin console - roles tab. Go into specific user’s role and grant them privileges to access the admin app. They can then access your admin app. This does not give the admin console (ui) for the user, which sounds like what you’re aiming for.


  • Mark

Having similar issue with 1.7.8 version. When trying to access a Remote SQL service called PlatformMasterDEV with a guest user, I am getting “Access to application ‘PlatformMasterDEV’ is not provisioned for this user’s role.”. I have enabled Guest users, Selected a valid Role that was setup with access to all methods enabled for the service. Please help. Having similar issue (same error) when trying to authenticate with a user that is not a SysAdmin by providing a valid session token id. The only way I was able to get it working was with authentication as a SysAdmin user.

We are not returning to 1.7.8 to resolve issues at this time. If this is not a result of your configuration, then it may indeed be a bug that was resolved in the 1.x product long after version 1.7.8 was released in September 2014. The last 1.x version was 1.9.4, released in June 2015. The current version is 2.0.

Thanks for the quick reply. I have installed v.1.9.4 and still having the same issue. Guest access is not working for Remote DB service. User based access to the same service works only when the user is a system admin. Any help would be appreciated.

Have you checked out this post that covers, from start to finish, making a service available to the guest role in 1.9.4? Make sure you’ve completed each step.