Getting 403 error when trying to access _proc

I have guest user access enabled and I keep getting ‘Access to application is not provisioned for this user’s role.’ None of the swagger queries are working for the guest user.

  1. I used my database admin username/pw for the service and no change (so it’s not a mySQL access issue)
  2. I have a role set up with * permissions for everything and the app is selected for that role.
  3. I have guest access enabled using the role specified in 2
  4. I’ve cleared the cache with no success.

When I run the query from within the API docs it works perfect. Outside of the admin console - no luck (I’m calling this through a rest service from I have the app_name specified correctly in the URL (otherwise I get the ‘No application name header or parameter value’ error.)

I’ve also tried authenticating and passing a session token, however, that’s returning a different error (username/password is not correct despite the fact that it is correct.)

You have covered the necessary steps to set this up properly. However I just tested following the same steps and had no issue setting up an identical configuration and calling it via RESTeasy. The only way I was able to get this exact error message was to un-select the API key that I’m passing via X-DreamFactory-Application-Name on the Apps tab of the Role configuration.

Are you running the latest DSP updates? What is your Admin Application version?

I figured out the issue. I had the case sensitivity incorrect on the URL.

1 Like