Changing max_records_returned doesn't have any effect on returned data


I’m working with dreamfactory 2.0.1. When querying a SQL Server through the API, it only returns 1000 records. Searching online we found that you can change the maximum number of returned records in config/df.php modifying the following line:
'max_records_returned' => env('DF_DB_MAX_RECORDS_RETURNED', 1000),
but if we modify that to 4000, we still get 1000 records.

We then found the .env file and tried uncommenting and editing this line:
to something higher, but it didn’t work.

Oh, and we also tried decreasing the value to something like 500 on both files and it still returned 1000.

So now what? Is it even possible to change the number of returned records or will it always be 1000 per query?

Thank you!

@Alex_Arraiza This is a known bug in DF 2.0.1. Upgrading to the latest DF 2.0.3 should resolve this and return the max number of specified records to retrieve. Restarting the instance after editing the .env file will ensure the changes take effect.