Error while installing V2.0-beta3

Hi all

I have a Windows 2012 Server, where I have installed Dreamfactory 1.8.0 (not running) and 1.9.1 (running). Now I want to install Version 2.0-beta3.

So I stop all Services (Apache-1 and MySQL-1). They got a -1 because it’s the original names are occupied by the 1.8.0 installation.

Then I run the Version 2.0-beta3 bitnami installer. (Tried both installers 32 and 64 bit).
But I keep getting the following error:

Error running C:\Bitnami\dreamfactory-2.0.beta-3\mysql\bin\mysqladmin.exe “–defaults-file=C:\Bitnami\dreamfactory-2.0.beta-3\mysql\my.ini” -u root --Password=**** shutdown: °C:\Bitnami\DREAMF~1.BET\mysql\bin\MYSQLA~1.EXE: shutdown failed; error: ‘Lost connection to MySQL server during query’

After the installation I have the new MariaDB, MongoDB and Apache-2 services. But no new MySQL service. I don’t know if the installer has a problem, because of the old MySQL services.

Reto E.

Bitnami has had some issues with their installers not properly distinguishing between existing MySQL DBs and ports when installing new MySQL DBs on same and different ports. What has BItnami support said about the issue? Not sure there’s much that can be done from the DF side on this Bitnami installer / DB issue.

I posted the error to the bitnami forum. Meanwhile I will install dreamfactory on a separate VM for testing purposes.

Thanks. Link here. I’ll contribute over there since it does appear to be in Bitnami’s wheelhouse and not caused by any DreamFactory code.