I got PUT HTTP 501 (Not Implemented) error when saving some options

I don’t know whether the others are experiencing the same error as mine, because I cannot find the solution anywhere.

In the DreamFactory Admin, I can save some options, such as adding Roles and Notification Preferences, but I cannot save some other options, such as setting Access to a Role and CORS.
When I look into my web browser console, PUT HTTP 501 (Not Implemented) error emerges every time I click the Update button.

I’ve done these:

  1. Deployed DreamFactory to OpenShift with DreamFactory cartridge (version 1.9).
  2. Tried different web browsers.
  3. Installed DreamFactory locally in Windows 7 32-bit and Windows 8.1
    64-bit with Bitnami installer (version 1.9.4-3).

and I still get the same error.

Is this a bug or I did something wrong?

Finally, I’ve found the problem.
This HTTP error is because a program in my PC creates a local proxy when running.
The proxy doesn’t support PUT and DELETE, and maybe some other methods.