MS SQL connection not creating API's

After some struggle I’ve managed to create the MS SQL service.

But now when I’m trying to view the schema no tables are loaded even if the refresh button is clicked. When trying to view the API’s for this service it reported - Unable to read api ‘mssql_pgwc’ from path http://xxx…/api/v2/api_docs/mssql_pgwc (server returned undefined)

I’ve also noticed in the DF log file also the following error message:

[2015-10-16 09:46:17] local.ERROR: exception ‘Symfony\Component\Debug\Exception\FatalErrorException’ with message ‘Wrong parameters for Exception([string $exception [, long $code [, Exception $previous = NULL]]])’ in C:\Bitnami\dreamfactory-2.0.beta-3\apps\dreamfactory\htdocs\vendor\dreamfactory\df-core\src\Database\Connection.php:466

From this it looks like a database connection problem but not sure how to trace it.

Any ideas on this?

What version of MS SQL?
Are you running the 64 bit or 32 bit package from Bitnami?
Have you followed the driver install process outlined here:

You can also gather more error information by opening your browser’s console and looking at the network tab when making calls.

I got this error a second ago, but it did not recur after clearing cache and reloading the admin app in the browser.

Got the same error on the UI side. Do not know where the DF logs are so could not check that.

Named my service sqlserver -> got this error (browser and service restart did not help)
Went back and removed the services
Created a new one with the same setting and named it test1 -> API docs worked as expted

Using the 3.0 sqldrv unofficial driver. Bitnami i64 bit install.

I have Bitnami’s 32-bit beta-3 with the official Microsoft drivers working with SQL Server without issue in Windows Server 2008 R2.

Same error. The ‘test’ installation on my local machine works as required, however installing on a server does not. “Unable to read api ‘###############’ from path http://###############:9000/api/v2/api_docs/############### (server returned undefined)”

I have beta 3 on the local (working) machine, beta 4 on the server.


I edited the code to show the error.

Connection.php ->
Line 466: throw new \Exception(‘Connection failed to open the DB connection:’ + $e->getMessage()); //, (int)$e->getCode(), $e->errorInfo);

Now the error is “Failed to connect to database”. However, I’ve tested the server connection and I’m able to connect, via SQL manager.

Is there more detailed logging of the connection attempt, or a concat of the connection string? I’d like to test externally to the application, however use the config from the application.


There is. The connection string is on the Config tab of the service definition, and I recommend checking the DreamFactory log located in storage/logs/ for detail on the error.

Just a note for anyone following this thread:

With the removal of the 64 bit Windows from the Bitnami installers page, there is no need to use the unofficial drivers referenced above. We DO NOT recommend using them. We ONLY recommend using the official sqlsrv drivers from Microsoft.