Problems Getting SQL Server connection setup in 2.0

I am trying to move to 2.0 and am having problems.

I tried to create a service to connect to SQL database and got a warning about SQL component not installed. I figured this was referring to the PHP driver (maybe I am wrong on this?).

I downloaded the Driver for PHP (SQLSRV32) and extracted it to >C:\Bitnami\dreamfactory-2.0.beta-2\php\ext

I added this to the end of the php.ini:

;sqlserver connection driver

Now all of the text fields are gone on the services page so I cannot create a service or update existing services. It is just a blank screen with the “create” button on it. If I revert my php.ini file back to original form it does not fix the problem. The only way I am able to get the services screen working again is to re-install.

Any ideas what I am doing wrong?

Microsoft SQL configuration requirements are the same in 2.0 as in 1.9 –

As for getting everything back to normal, try using API Docs or test_rest or a REST client to delete the offending service. Then clear the cache (from the config tab.)

I have narrowed my problem down more.

With a fresh install if I navigate to the php.ini file in the php folder, open the file, save the file without making any changes, restart the all the servers and login to the dreamfactory app all of my services now have a trash can icon next to them and look like the above screen shots.

I tried clearing the cache and rebooting server and it did not have an effect, I do not understand what you mean by: using API Docs or test_rest or a REST client to delete the offending service.

Very strange, even if I open the php.ini file and close it (no changes, no save) the problem occurs.

1 Like

What I meant was that even if the the UI is having problems, you could use the API to delete the service. The admin UI is breaking probably because you have an improperly configured service (or the drivers are not properly enabled for the service.) Deleting it would resolve that issue.

test_rest is a tool that comes built in to DreamFactory for doing quick API call testing. It is located at http://yourbaseurl/test_rest.html

You could also use a tool like curl or Postman to make the calls.

To list all services, you would perform a GET on /api/v2/system/service
Find the id# of the offending service and then do a DELETE on /api/v2/system/service/id# to delete it.

Obviously, these calls need to be authenticated with an admin account, so test_rest may be the fastest way for you to get this done. It has http basic auth built in. Just put in your credentials in the form. (see screenshot)

What service would I delete? this is a fresh install with no changes made to it. Only services are the ones that are automatically created on install. I can delete any of the services from the user interface I just cannot create or alter any of them.

So it appears my problem has nothing to do with the PHP.ini file or SQL.

Fresh install, setup admin user everything is working fine. close browser and restart the servers via the bitnami stack interface. Problem occurs.

The service I was referring to you deleting was the sql service that I thought was causing the problem. Clearly that’s not the issue.
Which version of the Bitnami stack are you running? beta1 or beta2?


I uninstalled the 1.9.4 then installed the 2.0 beta. All the services seem to be running fine. I watched them for a bit to make sure nothing was crashing. I tried changing logon accounts for the services to a local admin but it made no difference.

I am stumped on this. I am still not entirely clear on what is going on in the background of Dreamfactory so I am not coming up with too many good ideas for trouble-shooting and just grasping at straws.

I am currently setting it up on a Linux machine to see if I have any better luck.

Well any time you have an issue like that, check the dreamfactory log, and the apache logs.
In DF 2.0 the dreamfactory log is in storage/logs. (This is in the htdocs folder on a bitnami install.)
The apache logs should be in apache2/logs on a bitnami install.

Here is what is in my logs for errors. I tried to filter out what I thought was not meaningful hopefully I did not filter anything important.

Dreamfactory Log Errors after initial installation:

[2015-09-17 15:51:40] local.ALERT: Could not get cors config from DB - could not find driver
[2015-09-23 16:32:32] local.ALERT: Could not get cors config from DB - SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘bitnami_dreamfactory.cors_config’ doesn’t exist (SQL: select * from cors_config where enabled = 1)

Apache Log after initial installation:

[Wed Sep 23 11:33:02.629954 2015] [ssl:warn] [pid 4104:tid 280] AH01909: localhost:448:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 23 11:33:02.861977 2015] [ssl:warn] [pid 4104:tid 280] AH01909: localhost:448:0 server certificate does NOT include an ID which matches the server name
[Wed Sep 23 11:33:02.879979 2015] [mpm_winnt:notice] [pid 4104:tid 280] AH00354: Child: Starting 64 worker threads.
[Wed Sep 23 11:34:21.918882 2015] [:error] [pid 4104:tid 976] [client] REST Exception #401 > Invalid credentials supplied., referer:
[Wed Sep 23 11:34:24.837174 2015] [:error] [pid 4104:tid 992] [client] REST Exception #404 > Could not find a service for dreamfactory, referer:

I am experiencing similar problems when uninstalling and trying to go back to using 1.9.4, So I am assuming there is something that is not uninstalling and mucking things up.

I was able to solve the problem by installing the software in a different location and using a different port. There is possibly a problem with the uninstaller that does not properly uninstall the software.

There is a known issue with the Bitnami package and port numbers on install/uninstall. See here: Bitnami windows instalar on windows 10 x 64 (dream factory beta 2.0)

beta-3 is now available from Bitnami.