Api Error Required extension or module 'sqlsrv' is not installed or loaded on DF v2 beta 4

Hlelo, I just download bitnami windows installer of DF v2 beta 4, which supposedly fixes the issue with loading MS SQL driver but I keep getting the same error. Bug still present?
I am using sqlsrv mode.

Hi scmaverick,

I’m newbie. Testing DF for future development.
I experienced this bug when installing DF v2 beta 3. Found alternative (unofficial !) drivers here:

Seems everything works fine (retrieving schema, tables list, etc), except that not able to get records (error “Table &quot ;myTableName&quot ; does not exist in the database.”. I don’t know if this bug is related to unofficial drivers.

@scmaverick did you install the sqlsrv drivers?

@angelX that issue only exists if you installed Bitnami’s 64 bit package (which is the reason to use the unofficial drivers.)
The official MS drivers still work with the 32 bit package.

right, I have re-installed DF with 32 bits package, and works fine with official drivers (I was not happy using unofficial drivers).

Still having trouble retrieving one record, filtering by field value. As a newcomer to DF, I think I need a few more hours for testing.

Many thanks for the support !

1 Like

Aha! I installed the 64 bits version because its labeled as the recommended one, but you are right, I just remembered that Microsoft drivers only exist for 32 bits, I may have gotten confused as somebody once told me the 64b was already available, but I think he was talking about the linux version.
I will try 32b, hopefully it’ll work fine.

1 Like

How did the new Bitnami packages work out for you? They removed the 64-bit stacks and now have a GA release of DreamFactory 2.0.1.

Just a note for anyone following this thread:

With the removal of the 64 bit Windows from the Bitnami installers page, there is no need to use the unofficial drivers referenced above. We DO NOT recommend using them. We ONLY recommend using the official sqlsrv drivers from Microsoft.

Actually, not good. I managed to make it work at least for the service creation but it was never able to connect to the database, if I wanted to see the schema it would hang and timeout with an error. If I wanted to test the api calls with the embedded swagger it would fail saying that the token was missing. And that was it for me, only had a couple of days for testing this before changing to something else as I had no more time.
I never liked php integration with mssql anyway, starting with the fact that MS drivers as BS and only support 32b which is almost useless nowadays, so will probably wait for a newer more mature release before tetsing this again, but as long as MS doesn’t release any real fully working drivers for php will probably give up on this.

very true. even i couldn’t get this sorted out. I know DF provides good features but it fails for a seamless setup and integration with SQL database. Hope they quickly rectify this problem. I can’t wait anymore as my deadlines have already cross but still following :smile:

Just wanted to clarify a few things on this post.
Since 2.0 is now officially released these types of issues have been resolved.
Of course you will still have to install the sqlsrv driver separately. This is due to Microsoft’s licensing restrictions, not any kind of deficiency in the DreamFactory software.
If you’d like a seamless install for connecting to MS SQL, you’re welcome to try out a Mac or Linux bitnami image. They come with the FreeTDS dblib driver for connecting to SQL. No licensing issues there.

Just my $0.02, I think DF could do better than a cryptic error (API/module not loading) if this is a known issue. Or something during the installation phase of the Bitnami image telling me not to bother with MS SQL :smile: Or better yet a link from the installer to wherever the MS driver is located–I’ll have to Google this now as I’m still confused whether I should keep trying to get DF working against my SQL Server 2012 database… Looks like a fantastically exciting product but I was hoping the Bitnami approach would let me quickly get something up for testing/learning.

Thanks, EK

Downloaded 2.0.1-1 and separately downloaded Microsoft’s SQLDRV. Still not working…getting the extension not loading error… It’s unclear (without instructions) what do do after downloading the 8+ DLLs from Microsoft (Use the PDO ones? Need to rename to remove version number and TS/NTS? Need to edit php.ini? Include both drivers/extensions in the .ini file? If so in what order? Higher/lower in the extension list? etc. etc.) I was really hoping this would be easier to do… : - )


1 Like

OMG, thank you! I just assumed I could use the installer : - ) but this looks like it will be very helpful. Thanks!! -EK

(Edit to add more since I can’t add further replies as a newbie):

Ok, I was close–everything except using the TS vs. NTS versions of the DLL. I can now connect–will try creating some service defs shortly. Thanks again -EK

3 posts were split to a new topic: Issue with sqlsrv on 2.0.2 in Windows